Grasshopper millipede plugin problem



Hi! I recently downloaded the millipede plugin for grasshopper ( for my Mac (running Sierra) as it was in a definition that I wanted to play with. I added everything in the zip to my components folder in GH, closed GH and Rhino, and reopened Rhino. Rhino opened without a problem, but when I attempted to launch GH, even on a completely blank model, it gave me an error message that said “RHINO ERROR file name: src4/DotNetSDK/rhinocommon/c/rh_displaypipeline.cpp Line number: 1429 Code Type: X86-64 Version 5.4 (5E199w)” (attached below–hopefully you can see it) and once I closed the message, the program crashed. I can’t figure out how to delete stuff from my components folder without launching grasshopper, but that seems like the answer. I uninstalled and reinstalled the RhinoWIP, but when I opened up the new version all my GH plugins were still trying to load when I launched grasshopper and I got the same error message. Any ideas on how to fix this? Thanks! K

(John Brock) #2

Screen Shot 2017-10-11 at 8.37.08 PM

Delete the incom[atible plug-in:
Your Mac HD > Users > [you] > Library > Application Support > McNeel > Rhinoceros > MacPlugins > Grasshopper > Libraries

Somewhere in that neighborhood you’ll find the incompatible plug-in stuff.
Drag it into the trash


Thank you so much for your quick reply! I tried that, but I can’t seem to find anything relating to grasshopper/ grasshopper plugins on my MacHD. I tried searching for the relevant files that were in the millepede zip within my MacHD but nothing came up. Here’s what I have:

(Dan Belcher) #4

It looks to me like you are looking in the macOS “global” library (/Library). You also have a user Library (~/Library) which is where the plugins are stored.

To get to your Library, navigate to Finder > Go > Go to Folder… and enter the following path:
~/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Grasshopper/Libraries

Hope that helps,

PS: I should note that, by default, the user Library (~/Library) is hidden in Finder…that’s why you don’t see it in your screenshot. You can find instructions for changing this at the bottom of this guide.


Oh yes, got it! Thank you so much.