Grasshopper Inside running very slow

Hello,

When using Rhino.Inside Revit (heavy Revit model) I get 1-minute “spinning circle” each time drop a component inside grasshopper canvas (also when i click components that are already there). Same things happens I connect an output of any component (for example a panel with one item - a number) to any input (for example an ‘addition’ component)

I’d like to mention that i have all geometry (both in Grasshopper and Revit) previews turned off (in GH window and Revit “Rhinoceros” tab).

This happens even when i have nothing referenced from Revit - I built a definition without using any revit inputs for now.

Why does that happen? Are there any tricks to speed-up the way it works? It is quite frustrating to wait one minute each time I wish to add two numbers.

Thanks for your time and help.

Thanks for reporting this. I used a large Revit model and I can replicate the issue. We’re testing a few things out to fix this and will hopefully publish the fix in the next version

1 Like

Large Rhino models can do this too. One thing that can speed things up is disabling some or all of the Grasshopper AutoSave features in the preferences.

As well as disabling previews in Revit and Rhino.

image

2 Likes

Disabling previews especially in Revit can help a lot. I also use data dams, solver lock and disabled components to protect lengthy calculations.

Also, the new trigger component can be wired to multiple components and then manually trigger them all at once

3 Likes