Grasshopper hangs when references absent


#1

I have a definition which I use for fixing topographic data. The last time I used it, I referenced about 700 curves in a Rhino document, and saved the definition that way without thinking. Now when I open the definition with a blank Rhino file, I can’t do anything with it. As soon as I right click on the curve parameter component to clear the references or set something new it hangs - it’s looking for those 700 or so curves that are absent… Only thing that worked was to delete the curve parameter component and replace it with a new blank one.

–Mitch


#2

Hi Mitch,

I might did not quite understand you, but you could internalise the curves from .3dm to .gh file (meaning you won’t need .3dm file anymore): after referencing those 700 curves, right click on the “Curve” parameter and choose “Internalise data”.

Other than that, try disabling the solver first (Solution->Disable solver). Then open your .gh file, right click on your “Curve” parameter (the one that ‘had’ 700 curves) and choose “Clear values”.
Enable the solver (Solution-> uncheck “Disable solver”).

Does that help?


#3

Yes, there are a lot of ways to do this I guess… The main thing I’m worried about is the hang - I don’t know why it’s doing that, but I feel it should figure out quickly enough that the referenced curves aren’t there and let you right click on the component and set some others…

–Mitch


#4

Hi Giys

I’ve had the same problem and the only solution was to kill Grasshoer and then disable the solver before opening the file.
Internalizing date isn’t always a good solution as it makes a Gh file size grow rapidly and often is not welcomed.
I do think it is a sort of a bug.

Piotr


#5

Looks like @DavidRutten is aware of this issue and has already fixed it. Sounds like the same issue I think…


#6

Yep, it does… I guess we have to wait for V6 then… Maybe for Christmas? Well, it’ll also be OK in January… :smile:

–Mitch


#7

He’s making a list, checking it twice. Using some clever algorithm naturally :wink:


(David Rutten) #8

Yeah it’s the same issue. To get it to work on your current file, window select and delete the parameter with all the missing references, then replace it with a clean one.


#9

OK, thanks David, that’s exactly what I did…

–Mitch