Grasshopper for Mac available for testing

Yes, I know. First thing I thought was that McNeel is going down the same road again as they did with first implementing Toucan and then removing it. Then again - what’s in a name? :grin:

Nope, almost nothing to do with me. It’s mostly Dan and Curtis.

This is a fantastic release!!

Does Explicit History support ghpython components? If not, do you plan to allow Explicit History to use it, in the near future?

Thank you for the reply, and congratulation once again.

Thanks, ironic name choice. It’s deja vu all over again.

Looking forward to trying this!

Way to go Dan & Curtis, and David.

Scripting components are not yet ported, but they are on the list of things to do.

You don’t get the add ons, but I was trying this Peacock component yesterday on Windows and the GH definition opened up in WIP, great.

“Warning Parents”

Thanks again!

It’s a great news!

Though it doesn’t work on my mac yet. It starts, it loads and it stops at 100% and does nothing more :frowning:

I’m using 10.9.5, might it be because of this?


Thank you for the information Luis.


Is peacock made up of Clusters as User Objects? As long as the .ghuser User Object only relies on default gh components, it should work if it is saved in a definition.

Super mega cool! I opened a bunch of my previous definitions and all worked fine! (well, I’m not doing any really complex stuff…) I also created a couple of things from scratch, all seems to have the same feel as the Windows version…

What I noticed so far:

Since I’m working on a laptop with a single screen - all I have in Mac - it’s pretty annoying to have the EH/GH window disappear behind the main Rhino window if I left click somewhere in the Rhino window… Have to go through the Window menu to get it back, cmd+Tab doesn’t work (even if it did, it’s still annoying). The Windows version stays on top of the Rhino window, even if it’s inactive. I guess some Mac people might think this is a “feature”…

Single backspace key does not delete objects, you have to hit fn+backspace. Backspace alone works to delete in Rhino itself on my Mac, although I have seen some student Macs where it doesn’t.

The numbers in the sliders sometimes get too small or too big when you double click on them to change values.

Oops, just had my first crash, had several definitions open at once, and tried switching from one open definition to another via the menu, boom… Oh… @dan That one looks like it’s repeatable - tried several times… :confounded:

Anyway this is really cool, thanks guys ! --Mitch


@stevebaer and Curtis do all the difficult stuff…but it is your code elegantly “transmogrified.” All that rewriting you did years back to base it on RhinoCommon is coming to fruition, and for that we are thankful.

1 Like

We’ll change the name back to Grasshopper (and make it autocomplete)…we just wanted to telegraph how early this is. Lots of work to do.

1 Like

You know how much we love repeatable crashes! Please post steps (in a separate thread)! Which reminds me, I need to go make all the YouTrack issues public viewable. DONE.

Ok here’s the Grasshopper on Mac unresolved issues (that we know of) list.

Thanks for the report! The bug you mention is known:

This is really great. Now I have no excuse to learn it. Really unexpected but fantastic news

Good to know, I don’t know much about Peacock’s workings, the clusters are PW protected.

Time to test and play.

Thanks All!

Perhaps, but it may be something else. I’m seeing some (probably related) crash reports regarding a null/missing font, so it may be that the UI is trying to use a font that isn’t on your machine.

This is wonderful news! A massive thank you to everyone involved at McNeel who has made Grasshopper for Mac a reality.

1 Like

(and i’m only slightly exaggerating when saying that :slight_smile: )

such great news… can’t wait to dig in and start learning it… (be prepared for some questions fellas :wink: )

1 Like

not an exact solution (assuming you want grasshopper to always float on top of the rhino window)…

El Capitan has a feature called split view that may be beneficial here…
worth a try at least… here’s a quick video showing it.

so i take it the parental warning is a throwback to the original days of grasshopper? (plays on explicit)
if so, does it still do that on windows?
pretty funny.