Grasshopper components display as blank - no icons, no name labels, no wire nubs. How to find missing graphics?

Hi Grasshopper Community,

Components entered into the Grasshopper viewport are missing all identifying graphics - icons, text labels, and even the wire connection nubs. They are showing as blank rectangles but behave normally. As you can imagine, this makes creating definitions quite confusing!

Solutions I have tried (to no avail):
Installing/reinstalling both Rhino and Grasshopper
Zooming in & out
Selecting/deselecting “Draw Icons/Fancy Wires/Full Names” under the Display tab

What could be the issue here? The Grasshopper build version is 0.9.0076 being run on Rhinoceros 5 on Windows 10.
Please see this .png for a screenshot:
Thank you all.

Good news/bad news - good news is that I found a solution, bad news is that I never figured out the exact issue for the problem.

Previously I always started Rhino.exe from the path C:\Program Files\Rhinoceros 5 (64-bit)\System\Rhino.exe (“Rhinoceros 5 (64-bit)” in the Start Menu.)

I then instead tried the 32-bit version, which is Rhino4.exe from the path C:\Program Files (x86)\Rhinoceros 5\System\Rhino4.exe (“Rhinoceros 5” in the Start Menu). The Grasshopper plugin had no display/zoom issues in the 32-bit version of Rhino.

I did this after I reinstalled & updated Win10 though, not sure if that had any impact. Still not sure why my 64-bit Rhino/Grasshopper had this problem in the first place - my OS is 64-bit.

Many thanks to David for the help.

That’s the display you typically get when the canvas is zoomed out significantly.* Icons, labels, wires, canvas grid all fade out. For some reason Grasshopper seems to think that 156% is zoomed out ‘significantly’. Can you try zooming in really far to see if and when those visual elements fade in again?

Other questions:
What’s your Windows screen DPI setting?
Are you running this on a virtual machine?

  • Specifically, if the zoom is 60% or less than the default zoom.

Thanks for the reply David -

Zooming in yields no change, even all the way to 5000%. Zooming all the way out and then re-zooming in also has no effect.

My screen DPI/scaling level is set at 100% I am not running a VM.

Sorry if I double posted, I may have not replied directly to your comment.

Weirder and weirder. I attached a file which contains a single C# component. Once it runs it will put some text in the windows clipboard. Please paste it and post it here. It should be something like:

Default zoom: 200.0%
Lower zoom: 190.0%
Upper zoom: 220.0%
Canvas Fade low: 255#
Canvas Fade medium: 255#
Canvas Fade high: 0# (2.4 KB)

  1. Error (CS0117): ‘Grasshopper.GUI.Canvas.GH_Viewport’ does not contain a definition for ‘ZoomDefault’ (line 72)

Sorry if that didn’t help, I’m terribly confused as well! I dragged the .gh directly into the Grasshopper viewport.

Oh dear… your version of GH must have been since before that bit of code was written. You’re not part of Serengeti by any chance are you? It would be nice to know if this problem still exists in Rhino6 and the latest Grasshopper release.

I’m not a part of Serengeti. Is there anything I could do via reinstalling an older/newer version of GH? Thanks again :(.

I’ve attached the exported .cs here:

zoomreport.txt (3.6 KB)
zoomreport.cs (6.3 KB)

You cannot get the latest version of GH without also getting Rhino6 WIP. It’s free to join the Rhino beta process (aka Serengeti) if you have a valid Rhino5 license.

The code you posted is just the code I typed in. It was supposed to run on your machine, yielding the zoom data. But the code won’t run because it’s expecting to find functionality that doesn’t exist in your version.

I see! Without needing to use the WIP Rhino, would there be a solution for this then?

Thanks again, David!

I’m not sure. I still don’t know what could be causing this. If this is a bug that requires changes to the code, then those changes can only be made to the current version of Grasshopper, meaning you’d have to update to benefit from the fix.

If this is a bug which has already been solved in the current version of Grasshopper, there’s nothing left for me to do, but you’d have to update to benefit from the fix.

If this is a bug that could be solved by you changing some setting somewhere, then technically you wouldn’t have to update, but so far I haven’t been able to figure out if this is the case.

Hi David, I’ve updated my original post to reflect an update.

Thanks for telling me, and I’m glad it works now. I would have loved to know what caused this, but if it’s still an issue on Rhino6 (which is 64-bit only) I guess we’ll find out.