Grasshopper Component outputs make non bakeable


How can I force grasshopper component not to bake output geometry?

Your own component ?
In this case you can define the “Grasshopper.Kernel.GH_Component.BakeGeometry” method

Yes, I already did that way:

        public override void BakeGeometry(RhinoDoc doc, List<Guid> obj_ids)

When I click “insert” bake is working.
But when I right click at the center of the component and click bake icon, then nest_geo + all outputs are added to rhino.

Oh, it’s possible that the “Bake” is applied to the parameter.
Maybe implement your own GH_Param with your own IGH_BakeAwareObject
You can also implement IGH_BakeAwareData on your own GH_Goo.

But if you implement your own Param/Types,
Just discard the interfaces IGH_BakeAware*

I actually do not have my own parameters just some geometry of rhino that I temporary store in C# class.
How can I discard certain outputs? “Just discard the interfaces IGH_BakeAware*”

Yes I guess, but never test.


maybe a bug.