Grasshopper changes quote characters in panel

this may be an issue of personal preference, but I’m noticing that Grasshopper panels auto-correct normal single or double-quote characters (", ') to left and right quotes (“, ‘, ’, ”) on text input

can imagine this being nice for labeling or other instances where the text is getting read by a person, but for machine-readable applications like passing in a string to a Python component it gets to be a problem

would vote to have this not be the default behavior, or alternatively to be able to disable somewhere in preferences

Using the latest Version 6 WIP (6.15.19120.12036, 2019-04-30)

Hey @Carsten_Rodin,

Sorry for being very late to respond to this, but thanks for the suggestion. I’ve logged the feature request here.

No worries – for anyone else encountering this problem, I eventually figured out that this is a Mac OS issue rather than something specific to Rhino/GH. Under System Preferences > Keyboard > Text, you can just uncheck the “Use smart quotes and dashes”