Grasshopper automatically changes display mode

I just started having an issue with grasshopper where it is automatically changing my display mode. Every time I switch the display mode it briefly changes and then immediately switches back to wireframe. The file has a lot of geometry in it (city scale model) so I’m wondering if my computer just can’t handle rendering so many objects? It is definitely linked to Grasshopper because when I set Grasshopper to no preview or close grasshopper altogether it works. Any ideas how to get around this? Thanks!

You mean the Rhino display mode? Or the Grasshopper display mode?

Hi @DavidRutten. It changes the Rhino display mode. For example, I try to set it to “Shaded” or “Arctic” and it briefly flashes to it, but then switches back to wireframe. If I disable all grasshopper previews, I can switch freely between Rhino display modes.

I think I’ve found the issue. I had some DIVA components in the file that change the display mode (Sun Path). Even though they were disabled, it seems they were interfering with the display settings. Once I deleted them from the file everything else worked fine.

1 Like