Graphics Problems with 4k resolution - Fixed

unhandled

#1

Hello,
I recently purchased a new laptop (Lenovo Y50 touch with 4k screen). This laptop has an Nvidia GTX 860m. I have installed educational version of Rhino 5, with the latest update. When I open Rhino 64x the UI buttons are incredibly small and are nearly unusable. This also applies for Grasshopper when loaded. However when I open Rhino 32-bit, the UI looks normal, although the screen resolution suffers. When I do a SaveAs, the buttons become jumbled and I am forced to close and restart Rhino. Even when I reduce the screen resolution to 1920x1080 the buttons in the 64 bit version are still the very small size (I have also gone into the view options and selected the largest button size). Is there some workaround? as this is very disappointing that I will not be able to use the new laptop that I have specifically purchased to use Rhino.
Thanks,
Jacob

Attached Images in order: Rhino x64 screen capture, Rhino 32 bit screen capture, Rhino 32 bit after saveas screen capture:



(Pascal Golay) #2

@JohnM, you had seen something like this with the FIle Open dialog, is that right? Do you remember what the fix or workaround is?

thanks, -Pascal


(John Morse) #3

I can’t remember if there was a fix for the problem but I will poke around.


#4

Hi John, any luck determining the workaround? It seems like all the new laptops are now featuring high-res screens, this must be a common issue?
Thanks,Jacob


#5

Hi Jacob.
I am planning to buy 4K display. I will create new viewport in rhino to work in a Hi-res while all tollbars will stay at 1920x1200 px laptop display.
As a temporary workaround you can do the opposite - attach an external display, run Rhino on a second screen, make a new viewport to work on a high res laptop display.
This solution requires second screen so it is not suitable for travelling, but I know it works.


(John Morse) #6

We have done some work in V6 with regards to high resolution displays and tool bars. The tool bar bitmap sizes will scale by the Windows font scale factor in an attempt to make them easier to see.


(John Morse) #7

The issue with the Rhino user interface getting messed up after displaying the file dialog likely has something to do with a Windows shell extension that is getting loaded by the dialog box, I don’t think it is related to the high resolution display.


#8

Thanks Piotr - it sounds like that is the only workaround at the moment.


#9

Hey John,
Is the V6 WIP available, or when will V6 become available?
Thanks,
Jacob


#10

Hi John, any news you can offer me about the V6? I have been having so many issues with this new computer and Rhino 5 that I have tried uninstalling and re-installing several times. When I tried to activate my license on this computer, I received this error message: “your license has been validated too many times and cannot be validated again” (see attached scree shot). Can you please help me out, this is starting to become very frustrating.
Jacob


#11

Call @JohnM like this, with the @, and he will be notified.

I mean, this seems urgent engouh.


(Pascal Golay) #12

Jacob, please email tech@mcneel.com with the validation problem - include your V5 CD key in that email (do not post it here!) Someone will be able to help.

-Pascal


#13

Thanks guys!
I was able to resolve my validation issues, but I am still having the same problems regarding my user interface. I have tried everything including reducing my screen resolution to 1920x1080 and this still does not fix the scaling of buttons and tabs properly. Does anyone have any updates about a service release that will fix this issue or when the v6 WIP will become available?
Thanks
Jacob


#14

I just got a fancy new 3k display laptop myself and I’ve gotta say that it’s made my Rhino experience terrible. The icons are microscopic, and the external monitor is painful to look at (seems like no anti-aliasing), and the icons/tabs are sized all whack.

So here’s another user waiting for a V6 release with baited breath…

Thanks,
Ernest


(Stephen Maher) #15

Apologies for reviving a (relatively) old thread.

I’ve installed Rhino 5.0 SR10 on my new Lenovo Y50 UHD (4k display) and am experiencing the same issues as noted above. I haven’t found a remedy for the graphics scaling issues in both Rhino and Grasshopper (in addition to the toolbars and buttons, when GH is minimized it’s partially off the screen). So I’m wondering if there’s any hope for V5? Will this issue be addressed in SR11?

Thank you.


#16

What version of Windows are you running? In researching the subject, I have read indication that Windows 8.1 displays interface elements noticeabley better (scaled) than previous versions. However, I do not have any hands on experience to date and can not vouch for the accuracy. Seems logical though.

BTW - your reveal is rather timely. 4k should be an area of interest and growth in 2105.


(Stephen Maher) #17

Thanks for the reply. It does seem logical, but I’m currently running 8.1 (not the Pro version, if that matters). If it’s an OS problem, maybe Windows 10 will prove better. 7 is great. I can always do a clean install if need be.


#18

If you’re running 8.1, I’d assume not an OS issue. I’d be careful going back to Win 7 on new HW, especially 4k.

I had not carefully examined your post and made the assumption you had purchased a desktop 4k display, though both instances still relate. We have the need to replace a large desktop display, and will be buying more displays this FY as well, so have been digging into the 4K and applications in general.

Since the only thing around here close is a Retina MacBook Pro, we installed Win 8.1 via BootCamp. Same issue - tiny tool icons in Rhino and GH, mostly unusable unless one has Superman vision. Menu elements, presumable controlled by the OS, are OK.

Several icon based apps we tried are scaling their icons ribbons fine. Rhino is not. Since end users will be loath to commit to soon to be outdated technology for the next 4-5+ years, hopefully McNeel will be able to SR update Rhino for hi resolution displays sooner rather than later - read not wait for V6.

I think the HW manufacturers will push the competitive advantage (sales driver) of 4K this year, and users, once they experience the vast improvement in overall clarity, will not want to purchase soon to be “old school” displays. Sort of like the CRT/LCD rollover. This transition is well underway already with Apple laptops, and just starting with desktops.


#19

I had the same problem. What I did to fix it is turn down the resolution two notches (2048 X 1152) and then under display change the size of all items to 149%. Any percentage greater then you OSNAP’s will be funky.


#20

I use Rhino at 3K, on a laptop, and would like some High-Res TLC. Thank you.