Graphic Issues

#1

Hi @dan, I just started playing with V6, I couldn’t till now because I was using Sierra :frowning:
Today, just making some testing I came across with this issue. Running _Make2D with clipping planes were causing problems. I’ve recorded a video to make it clear https://www.dropbox.com/s/1z7u5ghdi3a6n3g/%20WIP%20(6.14.19043.12076%2C%202019-02-12)_graphic%20Issues.mov?dl=0

Also at the end of the recording, you can see I’m having black screen when switching from one viewport to another. Here you have also the file just in case.
WIP (6.14.19043.12076, 2019-02-12)_graphic Issues.3dm (3.2 MB)

Please don’t tell me that my MacBookPro Retina late 2013 it’s too old for V6 :disappointed_relieved:

Rhino 6 SR14 2019-2-12 (Public Build, 6.14.19043.12076, Git hash:master @ 7149c231e179e11960d27ac5c99c5713fe410254)
License type: Beta, build 2019-02-12
License details: Cloud Zoo. In use by: José Espizua ()
Expires on: 2019-03-29

Apple Intel 64-bit macOS Version 10.14.3 (Build 18D109) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,3
Machine name: Jose’s MacBook Pro
Language: en-GB (MacOS default)

NVIDIA GeForce GT 750M OpenGL Engine (OpenGL ver:4.1 NVIDIA-12.0.21 355.11.10.50.10.103)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB
Graphics: NVIDIA GeForce GT 750M
Displays: Color LCD (221dpi 2x)
Screen size : 1440 x 900

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
None

Rhino plugins
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.14.19043.1002

#3

Hi, nobody experiencing these issues?

(John Brock) #4

There are problems supporting these very old Macs with NVIDIA display adapters. Most them them date from 2010 or earlier. At this point, we do not know if we will be able to support these old systems with V6. Apple dropped them some time ago and their development tools do not support them like they do the newer display adapters they are using now.
We’re still trying to support them but no promises at this point.

#5

Really?, mine is from late 2013, and it works quite well yet. This is the first time I’m experiencing any kind graphic issue and I run lots of 2d and 3D software. I hope you can find a solution and let us these computers for a couple of years.

Thanks,
José

(Marlin Prowell) #6

@John_Brock This machine is running 10.14 and is currently supported by Apple.

We are currently playing whack-a-mole with graphic display issues - fixing issues on one GPU can affect how another GPU behaves. We should be able to support this configuration, but, as John said, having troubles with NVIDIA OpenGL graphics drivers.

(Steve Baer) #7

This looks like a duplicate of https://mcneel.myjetbrains.com/youtrack/issue/RH-49612 and most likely has nothing to do with Make2d. I suspect it is the action of clicking on the viewport labels to maximize different viewport configurations that is causing the black screen. Pascal can easily repeat this on his computer, but I haven’t figured out what the actual problem is yet.

#8

Thanks Marlin for trying hard, I appreciate.

#9

Hi Steve,

There are two issues in the video. The first one is related to _Make2D, sometimes this command will not generate any kind of geometry at all. It is usually more easy to see if you use a clipping plane. Other times, as in this example, the geometry will be only visible on some of the viewports. In this case, you can see how lines are not properly display in the perspective viewport.

The second one is the black viewport. From my experience, the more time you stay working in a session, the easier is to encounter this kind of graphical issues.

#11

Hi,
I just wanted to let you know that I installed Version 6 WIP (6.14.19057.13066, 2019-02-26) and I’m suffering the same graphic issues as with previous WIP.