Graphic issues

In Rhinoceros 8 I have no smooth/fluid orbit/pan/zoom, it randomly stucks.
Rhino 7 is ok, no graphic issues.


Rhino 8 SR0 2023-3-28 (Rhino WIP, 8.0.23087.12305, Git hash:master @ 308b13bf3b25029740e667ceba72704a53adf6a5)
License type: Commerciale, build 2023-03-28
License details: Cloud Zoo
Expires on: 2023-05-12

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 96Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon Pro 580X (AMD) Memory: 8GB, Driver date: 2-17-2022 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context FireGL 21.30.44.07 30.0.13044.7000
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 2-2-2023 (M-D-Y).
> Accelerated graphics device with 8 adapter port(s)
- There are no monitors attached to this device!
NVIDIA GeForce GTX 1080 Ti (NVidia) Memory: 11GB, Driver date: 2-2-2023 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- There are no monitors attached to this device!
NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 2-2-2023 (M-D-Y).
> Accelerated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 2-17-2022
Driver Version: 30.0.13044.7000
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\gabriele\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.4\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.6.4.0
C:\Users\gabriele\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
D:\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
D:\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
D:\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
D:\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
D:\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
D:\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.23087.12305
D:\Rhino 8 WIP\Plug-ins\SectionTools.rhp “SectionTools”

I’ve notice this. And it also jumps back to between views states randomly (Like you can orbit, but then jumps back to camera oriented to the beginning).

I’ve seen this too, and so has @wim but so far we haven’t been able to find a pattern. To me it happens not in every session either. Does it happen with you in sessions/scenes?
If you happen to find steps to reproduce this, let us know, thanks!

For me Rhino8 has a sluggish 3d viewport feedback. Also selecting objects it stucks for a moment, it waits and finally highlights the selected object. I never had this issue in Rhino 5 and 7. I have both installed on my workstation.
Another issue happens after many minutes of modeling/editing. If I want to create a new layer and I want to rename it, Rhino 8 is very slow to create the new name, every character pressed on the keyboard takes about one second to be shown. For example if I rename a new layer typing very fast, for example, “temporary_constructions”, Rhino takes 10 seconds to write the entire name.
I will create new videos about these issues.

A post was split to a new topic: Slow keyboard behavior

Hi @gabrielefx please post the video regarding the slow keyboard in the thread I just created, thanks

It looks to me like your monitor is connected to the AMD card through the port in the case and not to and of the Nvidia cards directly.

Yes, I have a Mac Pro 7.1 (bootcamp) with 3 graphics card installed on pci slots, another one through the tb3 port.
The Monitor 5K LG is connected to the Mac through a tb3 cable.
I use this “special” configuration without any graphic issues with Rhino 5, 7 and many other 3d apps.
I can plug the display to the Nvidia RTX to check if the issues is still there.
BTW, Rhino 7 works fine.

Please run the SystemInfo command in V7 as well.
I suspect V7 is not using the other GPUs either.

Having your monitor plugged into the wrong port is a problem in Windows Rhino and results in the same symptoms you are describing.
Because you have partitioned your drive and are running Windows natively, I don’t think the Mac hardware is a contributing factor.

Hi,
I’ve tested just now Rhino 8 WIP connecting the LG display directly to the 1st RTX2080Ti through a displayport cable.
Rhino 8 viewport now is fluid and smooth.
Probably in Rhino 8 there are new OpenGL features that in Rhino 7 aren’t available.

This is the Rhino 7 Systeminfo:

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Commerciale, build 2023-02-27
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 96Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon Pro 580X (AMD) Memory: 8GB, Driver date: 2-17-2022 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context FireGL 21.30.44.07 30.0.13044.7000
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 2-2-2023 (M-D-Y).
> Accelerated graphics device with 8 adapter port(s)
- There are no monitors attached to this device!
NVIDIA GeForce GTX 1080 Ti (NVidia) Memory: 11GB, Driver date: 2-2-2023 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- There are no monitors attached to this device!
NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 2-2-2023 (M-D-Y).
> Accelerated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 2-17-2022
Driver Version: 30.0.13044.7000
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\gabriele\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.4\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.6.4.0
C:\Users\gabriele\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
d:\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
d:\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
d:\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
d:\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
d:\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
d:\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
d:\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
d:\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
d:\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
d:\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

New update.
I switched the AMD 10 bit option. The drivers asked to re-boot.
Now Rhinoceros 8 is smooth exactly as Rhino 7.
I will investigate further using extensively Rhinoceros 8 WIP.

1 Like