Graphic glitches rhino 7 on MacBook pro M1 Max

Zooming in and out i get these triangles appearing , running MacBook pro M1 Max - Monterey

Hello- what build are you running? can you please run the SystemInfo command in Rhino and copy/paste the results here?


Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06342, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Commercial, build 2021-11-09
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 12.0.1 (Build 21A559) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro18,2
Language: en-GB (MacOS default)

Apple M1 Max (OpenGL ver:4.1 Metal - 76.1)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Apple
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 21845 MB
Graphics: Apple G13X
Displays: Unknown (255dpi 2x), Unknown (218dpi 2x)

Graphics processors
Apple G13X
Color LCD (1728 x 1117 @ 120.00Hz)
U32J59x (3008 x 1692 @ 60.00Hz)

USB devices

Bluetooth devices

Third party kernel extensions

Third party plugins
/Users/jonathancollier/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/KeyShot10Rhino7Plugin.rhp/libkeyshot_rhino_plugin.dylib

Rhino plugins that do not ship with Rhino
/Users/jonathancollier/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/KeyShot10Rhino7Plugin.rhp “KeyShot10RhinoPlugin”

Rhino plugins that ship with Rhino
/Applications/Rhino “Snapshots” 7.12.21313.1002
/Applications/Rhino “PanelingTools” 7.12.21313.1002
/Applications/Rhino “AnimationTools” 7.12.21313.1002
/Applications/Rhino “Renderer Development Kit” 7.12.21313.1002
/Applications/Rhino “Displacement” 7.12.21313.1002
/Applications/Rhino “Legacy Rhino Render” 7.12.21313.1002
/Applications/Rhino “Commands” 7.12.21313.6342
/Applications/Rhino “Import_OBJ” 7.12.21313.6342
/Applications/Rhino “export_xaml” 7.12.21313.6342
/Applications/Rhino “QuadRemesh” 7.12.21313.6342
/Applications/Rhino “export_OBJ” 7.12.21313.6342
/Applications/Rhino “RDK_EtoUI” 7.12.21313.6342
/Applications/Rhino “Export SVG” 7.12.21313.6342
/Applications/Rhino “MeshCommands” 7.12.21313.6342
/Applications/Rhino “Export_DAE” 7.12.21313.6342
/Applications/Rhino “PDF Export” 7.12.21313.6342
/Applications/Rhino “IGES Export Plug-in” 7.12.21313.6342
/Applications/Rhino “Import_SVG” 7.12.21313.6342
/Applications/Rhino “BlockEdit” 7.12.21313.6342
/Applications/Rhino “Export_AMF” 7.12.21313.6342
/Applications/Rhino “Rhino Render” 7.12.21313.6342
/Applications/Rhino “Import_DST” 7.12.21313.6342
/Applications/Rhino “PLY - Polygon File Format Export” 7.12.21313.6342
/Applications/Rhino “Import_AMF” 7.12.21313.6342
/Applications/Rhino “RhinoCycles” 7.12.21313.6342
/Applications/Rhino “IronPython” 7.12.21313.6342
/Applications/Rhino “Grasshopper” 7.12.21313.6342

Hello- does this happen in any file, or just some?


can you post the file? I have the same machine here, interested to see if I can reproduce-

any chance this mode is very far from the origin (0,0,0) if so, please move it to the origin and see if the problem goes away-

also does a machine restart change anything?

here’s another one. I’ll check later and see if it’s all files.

It’s a big file but you can download it here its the first file :
Crafter panel van (353,3 MB DXF)

I’ll try moving drawings to origin

The origin is fine. They didn’t do you any favors with that file, its 623422 curves, 1654 surfaces all on one layer.

The file itself is coming in fine (M1 Pro) but requires turning off layer 0 to do anything quickly. Is there a particular part of the file you can isolate? or export?

I’m seeing similar artifacts on Mac M1 Pro Monterey. Using clipping planes to control what is shown helps display performance in the large file.

It’s not all files only when they become more complex , if you zoom far out and in when in the perspective window that’s when they are most noticeable. If you draw some random curves and 3d shapes and duplicate them so the file size goes above 50mb you’ll see them. I’ve tried rebooting that makes no difference.

Do you have clipping planes in your models? I’ve seen this display driver bug with respect to clipping planes on Mac before which is why I’m asking

no clipping planes

Same in Rhino 8 wip but with testmetal on its fine.

I have the same issues with the new MacBook Pro m1 max
The file worked well (but very slow) on the HP elite book i7-6600 16gb
so to my surprise it was unusable on the Mac

have you checked for updates? WIP’s change frequently-

Do you have a sample file that exhibits this bug? We may be able to pass this on to Apple to see if anything can be done

I have the same issue with zooming. MacBook Pro m1max 14" 32 cpu cores and 64gb memory

The problem happens when scene has complex geometries, including lets say array of subd objects, or another time this happened when I had complex geometry originated from grasshopper . I will post example scenes later.

Also I noticed that subd geometry creation behavior is a bit different…

So after few days the glitch went away. When I reinstalled macOS the glitch went back.

Guys especially @stevebaer or any one from Dev. I think I have a theory of what is going on.

There is probably a bug in Rosetta2 emulator, and apple silently pushes update after the system is staged. Hence when you have brand new system Rosetta2 is not working properly, remember Rosetta2 is sepparate download that happens during initial run of Rhino (assuming that Rhino is the first app that you loaded on your m1 endpoint)

In my day to day life I am an Endpoint Engineer and my university has enterprise level agreement with Apple I can ping them regarding the issue. But I am fairly certain that the issue that initial deployment of Rosseta2 has some form of GPU bug and they are pushing an update silently, that’s why the issue is going away in a few days…

PS Something else that is supper funky going on with my endpoint. Custom Display Mode from your website Patent.ini is super slow, while modified Arctic.ini with all the lines toon shading is super fast. Am I correct at my assumption that Patent.Ini is using CPU and your app is not multi threading. While Arctic.INI is GPU based?