GHPython not visible in full screen

There is an is issue with GHPython editor that has been bugging be since the start of Rhino 6:
When GHPython editor window is maximized (to the full screen), its bottom is hidden behind the task bar.
Attached is an example screenshot.!

I have:
Rhino 6.13.19058.371, 02/27/2019
GHPython 6.13.19058.371
Windows 10 Pro, version 1809

This is not the case with my current PC. I checked and the same issue exists on other Windows 10 PCs, where Rhino 6 is installed.

@piac, @stevebaer, any idea if this can somehow be solved?

1 Like

This is a styling decision of Windows for windows with a small title bar. I think we can tweak this, though.
I’ve added to the todo list:
https://mcneel.myjetbrains.com/youtrack/issue/RH-54142

Thank you for the support Giulio!

Hi @piac , @Alain ,
Is there a chance the fix for this, will make it in time for Rhino 8.0?

Hi,
This seems like a Windows bug to me.
Is setting the windows taskbar to automatically hide an acceptable workaround?

Hi @Alain ,
I would not hide my taskbar.
Isn’t it possible to limit ghpython window to taskbar? On Windows 7 we had this feature with ghpython window.

Hi @Alain ,
Any chance you can limit GHPython component’s window to “stop” at Windows taskbar?

Hi @djordje , this will not be fixed as the new scripting component that replaces GhPython in Rhino 8 does not have this problem.

1 Like

Thank you @Alain .
So old GHPython (the current one in Rhino 7) component will be replaced by a new GHPython component in Rhino 8? Or did I misunderstand you.

All old scripting components will be unified into one new common scripting component. Your existing definitions will continue to work without needing any changes.

1 Like

Thank you once again for the answer and patience @Alain .
So there is no chance this GHPython issue will be fixed in Rhino 7?