Ghpython launch error

Hi guys,

I have some problems when launch grasshopper. Each time I launch grasshopper it will takes almost half of minute, and the progress bar will disappears after 10%.
So I tried to launch grasshopper in safe mode, and it will report following error:

Priority: GhpyLoader

The Rhino IronPython plug-in could not be loaded. It was either disabled, or it cannot load on your system.

What’s the reason that results this error? How to solve it?

And both rhino 6 and rhino 7 have the same problem

It looks like you are running Rhino if safe mode. Safe mode is only for diagnosing problems when Rhino is not running correctly. You should be running Rhino in normal mode.

Yes, because in normal mode, to launch grasshopper also has the same problem, so I ran rhino in safe mode to check what’s the error.

Grasshopper cannot be diagnosed properly in safe mode.

What’s the error in normal mode? Does Rhino print anything in the command line?

No something were printed in the command line in normal mode, but it will take more than half minute to launch grasshopper, and the progress bar would’t show after 10%. Which are showed in the pictures

How many plug-ins do you have installed on the mashine?

Can you also try the _GrasshopperLoadOneByOne command to see if one particular plug-in is slower?

There are almost 20 plug-ins installed already. The one takes most of time is GHpython.
I don’t know why because it used to be normal. The other plug-ins can be load fastly.

Is it possible that I installed ladybug tools, so grasshopper will takes time to launch?
Beacuse this is the only plug-in in my grasshopper that bases on python.

I wouldn’t know why, but any guess is of help.
Can you try uninstalling Ladybug and see if it goes away?



Giulio Piacentino
for Robert McNeel & Associates