GhPython external addon error

During the startup of Grasshopper I am getting There must be a unique PythonAssemblyInfo-derived type in __grasshopper__ module.
.image

This is on Rh8. I had the WIP/Beta installed. Uninstalled and did a fresh install of the current Rh8 version.

Any tips on how to get rid of the error are welcome. Thanks.

@AndyPayne do you have an idea what might be causing this?

@Gijs & @AndyPayne
I’m getting the same error with the Fennec addon (installed via the PackageManager in Rhino 8) on my desktop pc. On my Laptop the installation worked fine.

System Information from my Desktop-PC:

Rhino 8 SR3 2023-12-12 (Rhino 8, 8.3.23346.14001, Git hash:master @ 3b8659a0557b596b2d172939093022d2b67fd2e1)
License type: Kommerziell, build 2023-12-12
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16Gb)
.NET 7.0.9

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro M2000 (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp “MESH2SURFACE”
C:\Users.…\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\Bullant\23.10.24.0\bullant.rhp “bullant” 23.10.24.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.3.23346.14001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Thanks for your help!

Hi @Gijs

I’ve tested loading of my Rhino Plugin (written in GH) on the latest 8.4 release of Rhino 8 today and I’m still getting this error message:

The code runs FINE but I can’t ship my plugin to Rhino 8 users with this coming up.

Does anyone know how to fix or at least suppress this warning?

Cheers

DK

Hi all,

I would like to report that I am receiving the same error message when loading GHPython at the Grasshopper startup as well.
I had previously installed Rhino8 Beta that I disinstalled before installing Rhino8.

Anyone that have solved that by any chance?

Thank you

GHPython Issue

I asked internally, because I have no idea where that error might originate from.

Try starting via Rhino command line with GrasshopperLoadOnebyOne and say no to all 3rd party plugins.

Hi all,

as mentioned above i got the error message with the fennec addon. The message appeared for each component off that addon. As a result the fennec tab appears inside grasshopper but is empty:
image

I discovered that under GrasshopperDeveloperSettings the “Memory load *.GHA assemblies using COFF byte arrays” CheckBox was checked (on my laptop - where i didn’t get the error - it wasn’t).

I unchecked it, restarted Rhino and the errors where gone and all the components came back. Don’t know if this is the solution for all of you, but in my case this seems to solve the issue.

-Kevin

1 Like

@Japhy @Gijs I loaded with GrasshopperLoadOnebyOne, said no to all 3rd party plugins an still get the error from the McNeel IronPython plugin at:

When COFF loading is off, I do not get the error.

Interesting. Coff is supposed to off by default.

OK, good to know. I still remembered the times when it was default on.

An explanation why it is on in my clean Rhino 8 installation might be that a 3rd party plugin switched it on per default when I loaded GH normally. Then when loading without 3rd party plugins, it is still on.

Hi Guys,

I’m still getting this error on loading my plugin in R8:

Looks like there is a possible solution I need to check above - but did anyone get to the bottom of why this was coming up?

Cheers

DK

@kiteboardshaper Out of curiosity, did you ever have a stand alone IronPython version installed? I did, had to remove it for Rhino IronPython to work again. I am wondering if this is related.

Hi Guys,

I dont appear to have another Iron Python installed.

I had the situation today where the error message came up BEHIND the R8 window and cannot be accessed/clicked thru - meaning Rhino is stuck and need to kill the process in Task Manager.

I can’t have this happen to clients - it makes my plugin look like a complete hack.

Any further ideas to fix?

Cheers

DK

Would you mind looking into the directories below and give me a list of any *.ghpy files you are seeings. This error happens when GHPython is trying to load an IronPython compiled script.

  • %APPDATA%\Grasshopper\Libraries
  • %APPDATA%\McNeel\Rhinoceros\packages\8.0

%APPDATA% will resolve to your application data directory. You can just drop the paths into windows file explorer path box and it will resolve.



Image 540

@eirannejad KaroroCAD is my plugin, written in GH and complied with the Rhino Script Complier.

It launches from an Iron Python script that sets up the rhino document first.

There are a ‘few’ GH Python components in the GH script, with the whole GH file being 8700+ components.

Image 541

Cheers

DK

Okay do you know which Grasshopper plugin installs this file?

Hi @eirannejad

That is a very simple python script I wrote a few years back for one of my junior designers at the time.

Attached are files for you reference.

Thanks

DK
240309_SubD to Nurbs with faces packed example.gh (24.4 KB)
SubDtoNURBSPacked_5e2cab35326e42b3b4d8c8ec104ba61c.ghpy (22 KB)