Ghost points visible after surface split command


#1

Hi,

After creating a surface using the Sweep2 command. I wanted to cut it in half using the Wirecut tool.

The wircut didn’t actually work for this, so as a backup option I tried using the Split command instead, and that worked just fine.

To finish off the models shape, I want to use the setpt command to align all the outermost points along the same y plane coordinate. and in preparation for the setpt command, I went to turn on the points visibility. . . and was surprised to see that the points were still in place for the half of the surface which I had removed via the split tool.

At this point I’m not sure what the best path to take is…

Should I be looking to run a command which redraws (or regenerates) the visible half of the surface.

Or is there something I should have been doing to cleanup the model after having done the surface split.

While my main question has to do with the points that are left over from using the surface split command, why they’re still there, and how to get rid of them. I’m also interested in any and all criticism about the steps I’ve taken thus far.

If there was a better approach to have taken concerning the initial modeling steps, then I’m happy to hear about what that might be.

Also, as a secondary question, What’s the most efficient method for selecting all of the points along either to top, or bottom curves of this surface shape. Clicking them individually takes a while, and using the rectangular selection box can only get a few at a time.


#2

Wirecut is mostly used for cutting volumes, not flat surfaces. Split/Trim is more appropriate.

You might want to check the Help/Manual for info on what happens when you split/trim NURBS surfaces. If surfaces are not “shrunk” after trimming, the underlying base surface stays, Rhino just hides the trimmed portion.

http://docs.mcneel.com/rhino/mac/help/en-us/index.htm#seealso/sak_splittrim.htm?Highlight=split
http://docs.mcneel.com/rhino/mac/help/en-us/index.htm#commands/shrinktrimmedsrf.htm?Highlight=shrink

Select one point in the row and then run _SelU or _SelV (depending on the surface direction you want) to select the whole row.


#3

Thank You, So Much @Helvetosaur!!

I really appreciate the help you’ve offered me. I’d click on the solutions button now, but that doesn’t seem to be enabled for this forum.

Now that I’ve learned a little about how the underlying surface just gets hidden, but can be brought back by using the untrim command. I’ll have to think a little more carefully about when I should be using the shrinktrimmedsrf cmd.

In this case, as soon I saw that there were trace remnants left behind… I instantly felt that I should be tidying those up, because surely they were only there as a kind of hidden evidence to highlight my sloppy modeling skills. :slight_smile:

But of course the truth is a little deeper than that, and being able to go back in and reactivate the whole underlying base surface for future edits, seems to be a wonderful option to have.

So as usual, once again, it’s time for me to play around with a few experiments using these newly discovered commands.

Thanks Once Again, I really appreciate it.

Take Care,

Jim