GHA COFF or Direct loading


(Menno Deij - van Rijswijk) #1

Hi @DavidRutten

I ran into the same problem as the author of this post: http://www.grasshopper3d.com/forum/topics/how-to-define-per-gha-loading-mechanism

Somewhere on the second page you said:

Ah indeed. With _GrasshopperDeveloperSettings Memory Load option enabled and the load mechanism set to Plugin Default, the plugin doesn’t win. That’s clearly a bug.

I wonder if this ever got solved? I think I see the same: I define the assembly attribute

[assembly: GH_Loading(GH_LoadingDemand.ForceDirect)]

but Grasshopper only loads direct if the option is switched off in the developer settings. Before digging deeper, let me know if this problem has been solved or not. Thx!


(David Rutten) #3

Oops, missed this. Sorry. Looking now. It will certainly still be a bug on Rhino5 either way.


(David Rutten) #4

It’s a new problem, somehow Mono.Cecil fails to parse the assembly. Could simply be because I’m using an old version of Cecil which doesn’t know how to handle newer .NET version assemblies.

I’ve created two YT items for this:
https://mcneel.myjetbrains.com/youtrack/issue/RH-39607
https://mcneel.myjetbrains.com/youtrack/issue/RH-39608


(David Rutten) #5

I think I fixed the problem and if I’m right the next Rhino WIP will again properly respond to assembly load demands.
If not, please send me the GHA so I can test it over here.