Gh-python-remote

Sorry, I meant to write

python -m ghpythonremote._configure_ironpython_installation

I would have offered that you try the new CPython capabilities in the WIP version, Rhino 8, but I don’t think your license will work with that.

(rhinoremote) C:\Users\Vladimir PO>python -m ghpythonremote._configure_ironpython_installation
C:\Users\Vladimir PO\miniconda3\envs\rhinoremote\python.exe: No module named ghpythonremote
Hm, the same…

Maybe i should try it with trial license? Where i can download it?

So I guess ghpythonremote did not get installed properly. What was the result of the pip install gh-python-remote command?

https://www.rhino3d.com/download/rhino-for-windows/evaluation

Good evening!
Started it up. There was a problem with %PATH% . I couldn’t activate the environment in the normal command line. Only in Anaconda. + disabled antivirus. I manually added set PATH=C:\Users\Vladimir PO\miniconda3\envs\rhinoremote;%PATH%.
Thank you so much for your assist! I appreciate it.

But there is a new problem, he dont see numpy


BUT it is installed

I’m not sure why you needed the env path to be added to %PATH% but glad to know that fixed the problem.

About numpy, the correct syntax to use it in Rhino is:

import scriptcontext as sc
np = sc.sticky["numpy"]

And same for all other imported modules and submodules. They get imported in the remote CPython, and a reference to the module is written in the sticky dictionnary in IronPython. The “import_statements” output shows it too.