.gh .gha .3dmbak Windows icons gone (solved?)

34 PM

Hi, I just installed Rhino 6 for Windows (Educational Version) on a 2011 MacBook pro running Windows 8.1 with BootCamp; right after the installation the .gh, .gha and 3dmbak icons have disappeared leaving the same icon you can see in the picture. Looking into each file Properties, they are seen as GH File (.gh), GHA File (.gha) and 3DMBAK File (.3dmbak) respectively.

So far I have (unsuccesfully) tried the same solutions suggested here:
also from this old post: http://www.grasshopper3d.com/forum/topics/how-to-make-computer-recognize-gh-files-aka-bring-back-gh-icons1

I have tried (as suggested in both of the discussion linked above) to delete the .gh .gha and .3dmbak entries in


Closing all explorer windows before, then killing explorer from the task manager and starting it again as a new task, but somehow those extensions are immediately recreated.

I’d really appreciate if someone has found a solution to this nuisance and is willing to share it!



Hi Alessio - please try, and I have only slight confidence in this thought, but try this: In Windows Control Panel > Programs, locate Rhino 6, right click, choose ‘Change’ and then ‘Repair’ … any luck?


I tried, but no luck with that. Thank you for the suggestion anyways.


I got the .gh and .gha icons back.

  1. first: close all Windows Explorer windows

  2. then open regedit.exe and change the following keys:



to these values:

Rhino6.Grasshopper.Document (for every .gh entry above)
Rhino6.Grasshopper.Assembly (for every .gha entry above)

  1. OPTIONAL - search the registry for any “.gh” and “.gha” key to verify all values matched the above (this step is not necessary but I wanted to be sure the first time). I found these keys:

HKEY_USERS<your user code>\Software\Classes.gh
HKEY_USERS<your user code>\Software\Classes.gha
HKEY_USERS<your user code>_Classes.gh
HKEY_USERS<your user code>_Classes.gha

and they all matched the values above

  1. restart Windows Explorer task (via the Task Manager)

I am still looking for a way to get the .3dmbak icon back, but at list this worked for the .gh and .gha icon!

The fix proved to be only partial/temporary. I have both Rhino 5 and 6 installed (I still have to edit and share GH files made with v5), whenever I open Rhino 5 Windows re-creates the deleted registry keys and changes the value back to “Grasshopper Document” in the others, so the icons are gone again. I have to repeat the procedure above to get them back.

1 Like

Hi Alessio - if you right-click on a 3dmbak file and choose Properties, you should be able to change or set the association:


Thank you Pascal! Yes, it works, although I don’t get the greyed-out icon: the regular Rhino icon shows up instead:

It’s already better than the original situation, still, not optimal. I searched the registry for a key pointing to a DefaultIcon or similar for .3dmbak, but without success.

Hi Alessio - Hmm - I would expect a ‘repair’ for the installation to fix this but apparently not.


It seems to have worked for me, thanks!!