ggIFC to Rhino - missing elements


I’m currently try to render a model in rhino by extracting data from an ifc file. Most of the elements in the IFC file are correctly displayed in rhino by the script but a certain element is not being rendered.

The stuff that I have done: After reading the file by using ggIFC Read file, I pass it through ggIFC extract and then through ggIFC ProductGetGeometry. For most elements, I see ‘Closed brep’ as the output but for the particular element that isn’t being rendered, I see no output.

I don’t think there an issue with the IFC file since when I open the same file in another software, the missing elements do render.

Below is the extract from the IFC file for the element which isn’t being rendered.

#55887= IFCCARTESIANPOINT((145.791609467908,-2208.75058342271,91201.9273357633));
#55888= IFCDIRECTION((-0.388069604829551,-0.676498047767885,0.625901248739509));
#55889= IFCDIRECTION((-0.489297626823627,-0.424281953615234,-0.761953185058772));
#55890= IFCAXIS2PLACEMENT3D(#55887,#55888,#55889);
#55891= IFCLOCALPLACEMENT(#44,#55890);
#56328= IFCCLOSEDSHELL((bunch of # here));
#56329= IFCFACETEDBREP(#56328);
#56331= IFCSHAPEREPRESENTATION(#12,'Body','Brep',(#56329));
#56333= IFCPLATE('11ocj3RzX4s8hcyg0HRa61',#46,'PLATE','PL12*3795.7','PL12*3795.7',#55891,#56332,'ID41ca6b43-6fd8-44d8-8ae6-f2a0116e4181');

I would really appreciate your help in debugging this.

Also, do you have a pre-written code which does the job of rendering an ifc file in rhino? It would be really helpful in debugging. Many thanks!

Hi Yaga,

Thanks for the post. We certainly will help from our end to resolve this problem.
To do so efficiently, it would be great if you can share an ifc file with a problematic element.
You can do this private, and you can extract an element into is only small file if you can’t share
the project file.

One option for doing this is to open the ifc file into our tree browser (latest build is here, ggIfcTreeViewer v0.1.05.msi - Google Drive ), searching by globalid (ie
11ocj3RzX4s8hcyg0HRa61 from your text above), right click and use the isolate context menu.

Did you try importing it directly into rhino? If you’re rendering, creating mesh from the ifc shape rep might be desired (and faster than polysurface with many faces).

Let me know if you have problems extracting the element,


1 Like

Dear jonm,

It appears that the issue was with grasshopper. Restarting grasshopper did not work but when I reconnected the component, the rendering worked perfectly. I’m not quite sure what went wrong. But thank you very much for the quick reply.


Hi Yash,

This still sounds strange. Restarting Grasshopper should certainly resolve any issue if rewiring the component does. I’m not sure which version of the plugin you are using, but we are continually improving the tools so for a start updating via Rhino package manager is recommended.

If you see inconsistent behavior and it can be replicated, we will help troubleshoot it.



1 Like

I have updated rhino 7 but I still face the same error. I’m not sure if it would be easy to reproduce this error though.

I was just wondering, are these sort of errors known to occur when using data dam? I’m essentially supplying the data extracted from ggIFC Extract to a data dam and then to a bunch of different ggIFC functions.

It’s possible, I’m not aware of the data dam being used in this type of processing (not to say others haven’t done it, we get limited insight into use of the plugins).
Out of interest, are you confident in programming in c#, or python etc?
If so, I’d suggest Grasshopper is a great way to learn how to mine the data/geometry from IFC. But if you’re process is complex enough, I’d suggest developing your own code (ie grasshopper plugin with own component) using our plugin as an API might be an approach worth considering.