Getting two shadows in shaded mode?

I’ve been having issues with casting shadows in my shaded mode and wondering if there’s a way to 1) have it cast only one shadow 2) have it not be so long / stop it from getting cropped in an odd place. When I only have “Shadow only” checked, none of the shadows cast - and when I have them both checked or only Ground plane On, both shadows show up. Any help is appreciated!

Hello - yeah - the Shaded mode has three lights - you can edit the lighting scheme in Options> View >Display modes > Shaded


Thanks for your help! Any tips on how to prevent the shadows from cropping themselves? Is it the camera crop feature?

Hello - they may be cropped by the camera clipping if there is nothing else in the scene beyond the shadow - the test is to put a box out there and see if the shadow extends.