Getting rid of Spots on bottle sleeve


(Ryan) #1

So I’ve been testing out the demo of Brazil and comparing it to the current renderer I purchased (which I have never been happy with). I’m really enjoying the materials editor for Brazil. I setup a scene and have rendered out quite a few shots. I then wanted to add a light inside this bottle to mimic LED’s lighting up the inside. I did a single Rhino point light and put a focus on it. I like the way it renders out, but I am getting these spots all over the bottle sleeve. Any idea what this is from? I’ve have played with the light settings a bit including the exclude feature. But I’m definitely a rookie when it comes to Brazil lighting. There are also these rays coming out of the bottom of the bottle, I am not sure what those are from, they weren’t there originally but as I was playing with settings to remove the spots I somehow added those in there. I don’t think they should be. The light itself is located at the very base of the bottle with facing up, with a falloff just barely less then the inside of the frosted glass. And no higher then where the blue sleeve for the bottles lowest cutout. My hotspot is pretty small as well.


Any help is appreciated, I’m really enjoying this renderer, and can’t wait until I can pick up the full version.
I am using Rhino 5 SR5 and what ever Demo version of Brazil is available as of last thursday.


#2

Hi, posting the file might be the best bet.


(Ryan) #3

Unfortunately I am doing this for someone’s startup company. I can’t post the file as it’s someones design. that’s also why it’s such a tight shot and not a full scene. I would understand if there isn’t enough information to be able to fix it. I can always try to recreate it with some other model and post that.


(Ryan) #4

Ok so I took the scene, and deleted my geometry. Made something basic but with the same principal using the same materials and I no longer have the spots. It must be some sort of reflection or refraction off another object above that part. Although it doesn’t make sense why it would do it, but maybe it’s bouncing off the marble floor and back up into the sleeve. I’ll just keep playing with it. I know it would be difficult to help with out being able to give too much information on the file or geometry itself.
Thanks


(Brian Gillespie) #5

I see light leaking out the bottom - perhaps closing off the model so the light source only casts light where you want it to would help? It looks like there might be a pinhole or two that the light is coming through from the back side. Look for unjointed or naked edges in the scene.


(Ryan) #6

So the bottom is solid. The sleeve is a revolved surface. I’m not sure why the bottom is leaking light like that. There are naked edges however in my cutouts. But no naked edges on the bottom, and no non-manifold edges. I did a simple revolve object to make a solid. Then projected a pattern onto the surface. Split the object with the linework, then did a sweep of the sets of lines and rejoined. Not sure why I have naked edges. I have 55. But that would explain why I couldn’t fillet edge without some funky stuff happening. Thanks, I’ll rework the model and see if that fixes my spot problem.


(Andrew le Bihan) #7

OK - got it.

The problem is that you are shooting GI photons into the scene, but no where near enough. As a result, there are bright spots appearing where the photons have hit, but darker areas where the photon sampling hasn’t happened.

There are two solutions:

  1. Turn off the photon mapping - that will use brute force GI instead and you’ll get nicer looking speckled artifacts which you can solve by turning up the GI sample rate until you get a nice balance between speed and quality.
  2. Change the photon mapper’s sampler to “Count multiplier” and set it to about 50.0. That will cause the photon generation to take about 30 seconds longer, but the result will be way better. This might be the faster solution in this case, but it’s difficult to know.

(Ryan) #8

Awesome, thanks for your insight. I’ll tweak the GI settings, or turn them off completely depending on how the two finished renders look. I appreciate all your help.

-Ryan