Geometry skewed in UV Editor

Hi I am having problems with UVEditor in my Model. I have Surfaces that look perfectly symmetric when I unroll them and that is how I created the graphics I want to map on them. But in UVEditor they look irregular and somehow skewed and I cant get the texture to map onto them exactly. Any idea why this happens and how to prevent it?

Unrolled Surfaces:

Surfaces in UVEditor:

I hope the problem is clear. I am not an experienced user of UVEditor so maybe there is quite a simple straightforward solution for this problem.

Hello - I believe the only way out is to re-arrange the meshes - you can manipulate the UV meshes as needed, including moving vertices etc, to line them up onto your texture. In this particular case it does not look too difficult since the meshes are quite simple. Post the file if you like.

-Pascal

The Unwrap command in Rhino 7 has a Symmetry Tip option to define the center of the result you’ll get in the UVEditor, this may be what you need in this case.