Geometry dissappears when I zoom in

Hi. In the shapediver viewport I have this problem when I zoom in, how can i fix it?


I need at least twice of that zoom.

Could you please share the model for which this issue happens (or a minimal version of it) so our team can review the issue?

Sure ShapeDiver
Upload this dwg in the import for it to work
example facade_childp.dwg (35.6 KB)

Hi Mathieu! Any updates regarding the issue? Thanks!

This is happening because you have a very large scene (lots of drawing curves) and are trying to zoom on a single curve, which is very small in comparison to the size of the whole scene. In such a case, the viewer triggers clipping of geometry. Changing this viewer setting could help with your edge case but would create issues in many other models.

If you need to zoom that close to a specific curve, consider reducing the size of your scene. Do you really need to display dozens of curves at the same time? When you need to zoom on a specific one, you could hide the others, which would update the clipping behaviour of the viewer. You could also make your close generally closer to each other.

Hi Mathieu! I am coming back with the same question. Now I need to solve this problem. I am making grasshopper definition, and our developers are using direct embedding to implement it on our site. Can I do something in this case, so the curves are not disappearing? Before you mentioned clipping of geometry setting. Is this something we can change on our end? Any other options?

Hello @dfytz1,

it seems like you have set the maximum size of the file import to 0kb. Can you adjust the model so that we can test this issue again and make recommendations?

Cheers, Michael

Sure. In this model ShapeDiver
use this file in the import tab:
Drawing12.dwg (32.0 KB)
with “import from facade division” on the import tab turned off.
Then press compute.
Thank you

Hello @dfytz1,

Thank you!

The issue is still the same, you have a very large scene and are trying to zoom in on a comparatively small element. So it is only natural that some clipping might occur there.

I might have found a workaround for it though. Please try to enable the ground plane in the viewer settings (you can change it’s color to the color you are currently using as a background). In my tests this improved the behavior.

Cheers, Michael

1 Like