Gaps with surface fillet


I have two surfaces in which I fillet with radius of 0.5.

Afterwards using the showedges command I see there is a gap on both ends of the created fillet.

Is there a way to create the fillet from the start without having to resort to fixing these gaps afterwards?
Fillet Surface Gap.3dm (62.4 KB)

Probably the simplest here is to join the surfaces and then use FilletEdge.


The solution seems to be is to join the two surfaces and then apply a fillet edge.

The irony behind this is that I was just reading a forum topic in which someone suggested if you want your fillets to fail use fillet edge…in response to a posters problems.

FilletEdge has its limitations and its vocal detractors but it works very well in general.


Yes in this case…it was the perfect fit…It just seems odd that the fillet surface fails…I mean all the data is there. Must be a very simple algorithm that can’t take the extra step.

Hello - filletSrf worked just fine here.This is a perfect example of where to use Extend=Yes.


Yes…my filletSrf is set with Extend=Yes…but I get gaps.

Gaps… do you mean at the edges where the fillet meets the input surfaces? Join them all up… like FilletEdge does automatically - gaps gone?


Ok…yes…need to join.

My fault. The issue is that even though I wasn’t zoomed in too close, I still saw ‘visually’ in the viewport that ‘gap’ was there.

Thinking an actual problem with the created fillet and not simply a matter of unjoined surface edges.

I think there is a setting somewhere in which I should increase my resolution and/or remember to think better about what I am actually seeing.


Hello - please see


1 Like

Yes…that’s the one…thank you