Gap appearing between surfaces when rendering

Hi All,
I have a gap appearing between surfaces when rendering. The gap isnt really there, the surfaces meet perfectly at the edges, but show as a gap when in the rendered viewport and in final rendered image.

Can you upload a .3dm file with an expample of the geometry with the gaps? Files can be uploaded by dragging to where you type a post, or by clicking on the vertical arrow icon above where you type a post.

My guess, “Displacement-Map” is active with high value and “Edge Vertices” are not welded?
So command _WeldEdges or _WeldVertices eliminate this, but works only on Mesh.
No idea, how to fix this on Polysurfaces, maybe lower value.

Left, Mesh welded, R. unwelded

Brilliant …“Displacement-Map”…thank you !!

Yearh, I’ve been advocating a “weld edges” or a “weld render mesh at X angle” setting in the Custom Render Mesh settings. Hopefully it’ll pop up someday.

I added this thread to the feature request as well… Thanks.

I absolutely agree, indispensable rendering channel, this should work to 100%