Funky Zoom issue

I often scrollwheel zoom into an object when in the perspective window but then it is as if I hit a wall and it won’t zoom closer.

I have found if I orbit my view slightly, then I can zoom in again. What is this all about? Is there something I am doing wrong? This is pretty annoying. Anyone else experience this?

maybe use Zoom selected first if you have several objects in the file.

Hello - in Perspective it is possible for the camera to get very close to the target - you can see this if you turn on the camera (F6) for that view. The best workaround I know is to use Zoom>Target and not Zoom>Window in perspective views - this resets the camera target and allows scrolling to work again. If you are in very close, changing the view to a parallel projection is usually a better bet.
I changed my default alias for Z to Zoom Target, from Zoom Window.


Hi, it seems that this plugin is exactly for you: Walkie - A plugin for Rhinoceros with game-like walk navigation and mouse navigation improvements - YouTube

This plugin constantly places the camera target right under your cursor in 3D space that you can zoom in freely wherever you want, which Rhino doesn’t do for you.