Frequent crashes since Tuesday

I’ve been getting very frequent crashes since Tuesday evening (like 20+ yesterday.) It only happens when I’m running Rhino, but the crashes force me to restart windows by pressing & holding the button, so really completely crashed, and no crash report or anything like that. Even Task Manager is locked up. I can get it to happen fairly easily by rendering anything and cancelling repeatedly. Usually crashes on the second render. There is other crashing happening too, but not that I can repeat.

This repeatable crash only happens when I’m running the rendering on my external monitor. So at first I thought it was my weird display adaptor. I removed that (which forces me to run my monitor at a lower res) but crashes continued. So I removed the external monitor entirely, and with no monitor I get very few crashes.

Not sure if this is a clue, but before the update on Tuesday (or maybe it was even before that?) I was always being warned that I was missing Raytraced Materials - some warning popped up when Rhino was starting each time & I ignored it.

Rhino 7 SR5 2021-3-15 (Rhino 7, 7.5.21074.17001, Git hash:master @ 1e1438fea51381ad60d1d79103adb6c3a216e4a2)
License type: Commercial, build 2021-03-15
License details: Cloud Zoo

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [95% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro RTX 3000 (NVidia) Memory: 6GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel® UHD Graphics (Intel) Memory: 1GB, Driver date: 5-5-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version: 27.21.14.6172
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”
C:\Users\phcre\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0
C:\Users\phcre\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\raytraced-materials\0.1.5+v7.4\RaytracedMaterials.rhp “Raytraced Materials” 0.1.5.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Peter - does Raytraced materials show up in Options > Plug-ins page?

-Pascal

Yes it does

Hi Peter - if it is enabled there, try disabling it and then restart Rhino - does that make any difference?

-Pascal

That did not help.