Freeze editing material colour

After clicking the material colour display field in the material editor, my new Windows 11 installation of Rhino freezes with an alert sound when the interface is clicked, as if the colour selection window is open (but it doesn’t show up on the desktop anywhere). This is a project saved with textures and transfered to the new machine, so that may play a role.

This could be caused by a variety of different things.

Please run the Rhino SystemInfo command and post the results so we can see what resources Rhino sees on your computer.

Thanks

Thanks John. The basic problem may be that certain windows don’t display so the system holds waiting for user input. The same thing happens with ViewCaptureToFile. Here’s systeminfo:

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Commercial, build 2022-03-08
License details: Cloud Zoo

Windows 10.0.22000 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 8-20-2021 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA RTX A5000 Laptop GPU (NVidia) Memory: 16GB, Driver date: 11-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.76
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-23-2021
Driver Version: 30.0.14.7276
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

For now I am holding off using my new (Windows 11) computer for Rhino until this can be resolved. Haven’t put Rhino completely through the paces on that machine yet. If there are other windows which freeze Rhino when they launch and disappear, it could be trouble.

I called tech support a while back. I’m told that this is a very occasional problem with Rhino (though I’ve only seen it while testing my Windows 11 machine) and that Windows 11 is still too new for techsupport to know if its a particular issue.

I would update both your intel and nvidia drivers to the very latest available, and also update rhino to the latest service release (currently 7.18)

go directly to intel and nvidia for your driver updates, do not use the device manager, as it fails almost 100% of the time. /

when you install your nvidia, make sure to use the custom install option and check “clean instal” then restart your machine, and then restart rhino.

any better?

When that happened, the installation was in a fully updated and new installation of Computer, OS, RHino, and Video card updated as you describe. I puit the computer aside for a while, and there have been some updates since, and it hasn’t happened for the past few weeks I’ve started using this new computer again (with Rhino).
DG

right, but updates have occurred since then. Please grab the latest of all mentioned above,

also make sure your windows update is fully updated, you may have to run it more than once as windows updates can be cumulative.