Force a command to start with my chosen option

I would like the command ‘extend line’ starts with ‘line’ option and not natural. Is this possible / ?


There is no command “extend line”, just “Extend”. There is a tool icon with a tool tip “Extend Curve”, but that also generates “Extend”. I tested it in version 5.3.2., and the option you selected last (and completed) is remembered.
If you would like to start it with option “Line” regardless, you will have to customise your command set.


Thanks man! Do you know how to customize the set?

save the following as a macro. you can alias it, or make a new command and use a short cut.

_Extend _Type=_Line

From the menu: Rhinoceros > Commands > Customize. You will be prompted to make a copy of the Default command set. Then the dialog opens, and you search for the command icon name, in this case Extend curve. In the lower-right part of the dialog window, you will see the text of the macro belonging to this icon. However, to my surprise, in my set at least, it reads ! _Extend _Pause _Type=_Natural which suggests that the default option of the command is Natural, but as I wrote earlier, the command always opens with the last used option selected.
I would have suggested to change “Natural” to “Line” in your case, but now someone more knowledgable should advise I am afraid.


i believe those are predefined macros which we see there, there is also one called extend by line, it looks similar to what i suggested but with an enter in between which i found seems obsolete. can you try if my macro works? i am recently pretty unsure what works and what not. maybe i have to consider keelhauling my copy.

I think I have got it, the command Extend normally asks you to select a boundary object, if you do that the option “Line” will be executed after selection of that option. When you ignore to select a boundary, the command executes the option type given in the macro after the _Pause (which is pausing to wait for user input).
However, when I changed the command macro include “Line” instead of “Natural”, the behaviour is still the same i.e. it reverts to the “Natural” option. What is going on? And yes, I restarted Rhino before checking.

Thanks a lot for taking your time. I guess I will need to wait to see how to apply this change without corrupting my Rhino copy . I am afraid of messing everything up.

Thanks so much

Thanks Richard! I guess I can try, but i would not like to corrupt my rh copy by applying this kind of changes since I am not so experimented with scripting.

its not scripting actually just using the commands which are there thats called macros like in microsoft word :slight_smile: it will not corrupt your rhino at all, implementing aliases or new commands which are made out of other commands does not change the actual command. you can also delete it again any time, that really should not worry you.

did you add any aliases already or are you using the short cuts and commands straight out of the box only? if adding anything simple like this would corrupt rhino then this would be a serious bug to report.

Hi Bruno - in Preferences > General >“Run these commands every time a model is opened”, add this macro:

! _Extend _Type=_Line _Enter !

This will fire off the command as Rhino starts, set the option, and then cancel.

Any luck?