Font Appearing When Script Runs

I wrote a script and using the name of directories which contains the Czech letters (with diacritic - like č, ž etc.). when I run the script using debugging the letters sent with Command are ok, but when I save it and load the script again the letters are presented with other font set (that means there is difference between the directory name and the name I sent to Command Line). I tried to change the _Options _Appereance _Font - but it didn’t help.
Could be there any advice please?
Thanks Vilem

If you copy/paste the following at the top of your script, does it work better?

"""Place at top of script for Unicode UTF 8 encoding"""
#!/usr/bin/env python
# -*- coding: utf-8 -*-

–Mitch

Thanks for reply - but I was writing that in RhinoScript now - not in Python , is there any variation please?

Dunno, does this help any?

–Mitch

unfortunately not - still finding the solution - using this code:

Dim sFolder
sFolder = Rhino.BrowseForFolder("\\3dt-dataserver\", "Vyberte adresář poptávky nebo zakázky", "Překlad souborů")
If VarType(sFolder) <> vbString Then Exit Sub

Set oFSO = CreateObject("Scripting.FileSystemObject")

Dim oFolder
Set oFolder = oFSO.GetFolder(sFolder)

I still see the invalid letters in the GetFolder window - and then again after selecting it.

I tried to set oFSO.Char=“utf-8” - found somewhere - but do not succeed
vilem

Does using the Shell’s version of 'browser for folder" work any better?

https://msdn.microsoft.com/en-us/library/windows/desktop/bb774065(v=vs.85).aspx?f=255&MSPPError=-2147217396