Fluids in topography

Hello,

i dont know what im doing wrong, i cant achieve to record the movement of fluids on the topography,

hope you can help! Thank you

1 Like

Switch the run toggle to true.

Couple things Iā€™m noticing:

  1. Use the bouncy solver so that momentum is preserved.
  2. Connect the populate geometry output to both OnMesh and Load. Do not connect them into sequence.
  3. Connect the outputs of OnMesh and Load into GoalObjects. Do not connect the Load output into Threshold.
  4. Make sure you unit Z vector is negative, with nothing plugged into your unit Z component, it is positive.
  5. Plug in a number slider into the kangaroo Damping input. I had success at .3 damping.
  6. Turn the toggle on!

I was able to get the script to work this way, with one little glitch that hopefully someone else can solve: The points are following the topology of the mesh, but below the mesh at the distance set by the load.

It looks like you are using the definition from here:


but as pointed out, it looks like the Load goal has somehow been accidentally connected to the wrong input. Once this is changed it should just be a matter of setting the toggle to true. When you want to clear the traced particles, you can click the X of the Record component.