FlowAlongSrf Problems - It's just making a planar copy?

Hello all. I’m having a very frustrating problem.

I am trying to end up with the final result of a globe with a world map on it. A method I decided to try was to reverse the Mercator projection process by taking a vector world map, putting it onto a cylinder, then projecting that onto a sphere. (If you have any better ideas, please let me know, because I’ve been ripping my hair out for over a week trying to get this figured out. I never thought putting a map on a globe would be so difficult!)

Here’s what I did:

  1. Make a cylinder
  2. UnrollSrf to get the side as a planar rectangle
  3. Put vector map onto rectangle
  4. FlowAlongSrf to put the map onto the cylinder.

However, instead of getting my curves nicely projected onto the side of the cylinder, all I got was a vertical planar copy of the map.

I have since tried everything I could to get it to work, and haven’t found any solutions. I’ve tried using UnrollSrfUV instead of UnrollSrf, I’ve tried splitting it up into half-cylinders and doing it one half at a time, I’ve even tried using a really simple little curve doodle instead to see if maybe the complexity of the curves is causing the problem. I just keep getting the same result.

First off, do you guys think this will work? Will projecting these curves onto a sphere (most likely half at a time) leave me with a globe with a map?

Second of all, what the heck is up with my FlowAlongSrf? Why isn’t it doing what it’s supposed to do?

Hi @DeeTee

Without a file it’s hard to tell, but my guess is, that you have Rigid=Yes set in options for FlowAlongSrf, so that the curves (probably grouped) are treated as a single, unbendable unit. As for the “projecting onto sphere part” - it should work, although my cartography skills (or lack thereof) aren’t sure of how precise it’ll be.

HTH, Jakob

try ApplyCrv.
https://docs.mcneel.com/rhino/6/help/en-us/index.htm#commands/applycrv.htm?Highlight=ApplyCrv

Hi @DeeTee

Is your vector art a block? If it is you’ll need to explode it first.

Edit: Since a block is meant to be used as a reference and not necessarily manipulated in that manner.

I’m not sure if this was it or if it was because I repaired my install of Rhino, but when I went to try again it was set as rigid=no and it worked. So I’m not sure what it was before (although I swear I tried toggling all of the options just to see what would happen), but in any case, this worked now.

The only problem is, now a whole bunch of my curves magically disappeared! All the major landmasses are gone, and all I have are some islands and Australia. I’m not sure if it’s just too many curves or something, but most of the map is gone. Any idea why that would happen?

Huzzah! This worked!

Now I just have to find out if I can actually project this onto a sphere somehow :slight_smile:

It looks like the relationship between a sphere and a mercator projection is not a simple geometrical projection. :frowning_face:
http://mathworld.wolfram.com/MercatorProjection.html

I actually switched to a cylindrical equal area projection, hoping I could find a way to project along the normal of the cylinder in towards the sphere.
However, I am about at my wits end here and just ready to give up. I can project towards a point, or towards the plane - but I can’t find a way to project inwards towards the center of the cylinder.

Currently, I’m trying FlowAlongSrf straight onto the sphere itself to see what I can get that way.

Pull will project from a cylinder to the surface of a sphere along lines which pass through the center of the sphere. All lines which pass through the center of a sphere are normal to the surface of the sphere.
http://docs.mcneel.com/rhino/5/help/en-us/commands/pull.htm

However that’s not how a cylindrical equal area projection works. You need to find a simple cylindrical projection which I understand is rarely used for global maps.