Flow command warps the unbent portion why?

Hi, V5,
I recall bend command where one creates a line and a recipient line and the object bends accordingly.
One gets asked to pick the source line, then the final shape line in a similar area, and the object bends.

I have checked dir, yet wrong end of pin bends round, it doesnt ask me to select the source line then the destination, it says select spine start, so I pick the end of my straight line which is to be found part way along the pin, then it asks pick end of spine so I select end of curve, then it says pick a point, (I dont recall that stage before) so I pick a point part way along curve, and the wrong end warps round !

Split pin V ends causes 85Mb jump in file size.3dm (150.5 KB)

I discover its Flow I need.

However I use flow and the result is kinked and warped in the area that didnt get ‘flowed’

see attached, why has that happened ?
Split pin V ends FLOW command but now disfigured.3dm (294.2 KB)


Hi Steve - it’s hard to know what is incorrect since you do not provide the starting object but I think you are, possibly, referring to this?

That is a meshing artifact, and can be tuned out with custom mesh settings like this:


yes, that large KINK, see that underside in that area, I presumed it was visible.
I have been told my bloated file size problems are due to mesh settings, and all I alter is the max angle to stop getting faceted curves.
Now frightened to alter anything !

I need to alter 35deg to 15 in files given 35, if thats the only baddie, then I can relax !

are these ok in that respect ?

How does one know what settings bloat and what settings dont ?


Sorry, I have no idea what this means. If you set the render mesh on that object as I suggest, the display should clean up.


Hi, where it says maximum angle I had discovered if I set it to 35 then the surfaces that gave a faceted octagonal straight line segemented appearance to a hole, became an appearance as it should be, the faceted holes went smooth, I am now told 35 is far too much, use 15, 35 bloats my files.

so thats what I mean by altering 35 to 15.

Your settings here wont bloat the file, as that 35 degree angle did.


Well, I would try get some understanding of the mesh settings

It is hard for me to see how increasing the angle will make a larger mesh than a smaller one. In any case, a custom mesh for these objects with the setting I used will probably make that problem just go away. I don’t know about the angle setting bloat.


Hi, Pascal,
I have applied your settings and the warp etc goes.
I experimented with and without angle 15 deg, as holes were faceted a bit, effect on size :-

Made destination file as well as split pin as per Pascal settings on mesh with 0 for angle,

So angle 0 to angle 0, copy paste pin to chock, all as Pascal, sees save 3,322kb


make destination as Pascal and make angle 15.
paste pin in,
Angle 0 to angle 15, rest as Pascal , sees 3,724 Kb.

Result smoother holes and still a normal file size. :slight_smile:

Prior to this I had pin as Pascal and pasted in to destination file, took 15 secs and save took 47 secs.
file became 200Mb !
35 as angle has an incredible impact !

I see the McNeel article Rhino Mesh Settings [McNeel Wiki] on meshes shows 35, thats where I got that idea of 35 angle from !

However I have just posted at:-

using Pascal mesh settings for pin and the split pin is very ragged and faceted, why ?


Your file had 0.35, not 35.