Flipped Frame for Sweep1

In the attached I am trying to do a Sweep1 using the curves, through the frames and to a point at either end.

Why is the last frame always flipped?

This happens even if I copy an unflipped frame and paste it, position it at the flipped frame and delete the flipped frame?Problem56.3dm (60.7 KB)

I used the Dir command first to check the direction of the cross section crvs and they were all the same. My hunch was one would be flipped but I get them all pointing in the same direction here with Dir and Sweep1. I tested in Rhino 5 for Mac 5B161 as well as Rhino 5 for Windows SR12. Are you using a different version on Mac?

I was using 5B161

Weird… I’m not sure why I don’t see this. Are you dragging a fence selection over all the cross sections? I wonder what any other users see… can someone else try this too?

What’s different between what he shows in his image and the posted file is the seam point of the frame curves - they’re different. In his image, the seam point is on the rail at the triangle’s acute angle, whereas in the posted file it’s along the 90 deg corners of the triangles. I suspect the posted file is not exactly the same as the one used in his example image… unless he moved every one of the seam points during the Sweep1 command or something…


Good point Mitch… I neglected to absorb that detail.

I just downloaded the file I posted, and did the same and got the same:

I did:

  1. Sweep 1.
  2. POINT
  3. Selected all the frames.
  4. POINT

And that’s the state at the point of the image.

OK, got it, the “point” part is what we were missing. I do see the same thing. The “Natural” command line option works OK, but not “Automatic”

This seems to work “better” in the next version, BUT mainly because the Automatic and Natural options now do the same thing - no possibility to put the seam automatically on the rail anymore.


Thanks for the extra info. If you click Automatic again the directions will all match with the seam still on the rail. @Helvetosaur this works the same here in the WIP, I can also use Natural the same as in 5B161. So I think it’s unchanged… am I missing something?

I’m testing in the Windows V6 WIP… :smile:

Ahh… I see. I’m not sure why that changed there making Automatic and Natural do the same thing. @lowell is this on purpose? Just to be clear, use the file at the top of this thread in the v6 WIP

I may be missing the point but…
Automatic mode tries to get all of the shapes going the same way.
Natural leaves the directions as they are in the model.
If they’re already going the same way, Automatic doesn’t have anything to do so the results look like Natural.

Thanks for explaining @lowell. The two options do different things in PC v5, Mac v5 and the Mac v5 WIP which is why I asked. Natural or Auto changed where the seam was in this test case.