Fixing Rhino WIP Startup Faliures

Hi Brian,

This indeed fixed the installed WIP.
Everything loads fine and seems OK.
After closing I got the prompt to install the latest update. Upon doing so I got some error dialogs…hmmm…I rebooted Windows and tried again to allow for the installation of the update:

clicked 2 times OK as the dialog pops up 2 times, then get this:

Hit OK and the installer progress-bar empties out in reverse and installer bails out.

Any ideas you want me to test.

It’s late here so maybe no reply until in about 10 hours.


Perhaps try a manual download and install to see if that is any smoother?

Hi Brian,

this worked for me as described with one small difference: After i´ve removed the registry entries and deleting the *.lic file, i´ve entered my license key and registered. Once the validation completed, i still got the litle dialog that the wip expired. I´ve chosen “continue” and Rhino was loaded without toolbars and save disabled. Then i´ve just reopened Rhino and the toolbars and plugins loaded fine. I´m using the built of yesterday (6.0.14274.3191) which i´ve downloaded manually. So for me it seems to be up and running again.

thanks !

Hi Willem,

Please try uninstalling Rhino WIP and then install from scratch… does that fix it?

@brian OK, on my workstation here at work I followed the procedure in the first post exactly and it seems to have worked flawlessly. I had previously installed the most recent build.

After having deleted the indicated registry key and closed Regedit, I started Rhino 6. It asked me for my key, I entered it and then the validation screen came up. I went through the validation procedure (skipping the registration part) and validation was successful. Rhino 6 then opened with toolbars (my custom workspace) and all.

This part didn’t happen though:

Rhino started up right away after the validation without telling me it was expired.

Anyway, here at least, things are working, will now try on my laptop…


Fixes my system.
After the old WIP showed no toolbars but had a valid license, I installed the current build and got the License Expired pop-up. Now everything seems to work again.

The process outlined in the first post worked for me.

OK, on my laptop, the procedure also worked. This time I did get the “expired” message again when I opened V6 the first time afterwards, but then once I closed and re-opened, it launched correctly, toolbars and all.

So, all good here for the moment… Thanks!


Hi Brian,

Finally got to set this up and I’m happy to inform you all is working again after a
full un-install | download | re-install.


Worked for me.
Updated to the 2014 10 01 .

Now all is fixed!
Ver. 6.0.14280.10341, 07/10/2014 installed and running without problems.

This also worked for me earlier this month.
Two days ago I got a message that a new version was available and I installed that one - or at least, I tried.
Now I am getting the following:

After that second one, the installation rolls back.
Any ideas?

same thing here.

@wim and @Ernest
Have a look here for the probable fix:


Of course. Thanks Willem.


Well, it worked for me the first time around but doesn’t any longer…

Same thing as Wim and Ernest… --Mitch

Same problem for me too.

The cloning operation for Brian Gillespie is stalled at 63%, but we’re hoping it will complete soon so that he can resolve this issue.

Might be the same bug as in the WIP installer :stuck_out_tongue_winking_eye:

Sorry could not resist, good luck getting things back on track.