Fix imported iges surface 'naked edges'

First thing I see is that the model was never a solid. The surfaces are facing in different directions and this surface isn’t trimmed as you can see:

So here you need to rebuild the errors.

Thanx Holo.
Yes, I know that.
I fixed a bunch of problems, but can’t seem to get this to solidify in Inventor.
I sent you the original file.
What Rhino tool did you use to face normal direction?
Why do I need all face normals in the same direction?

I used the “color backfaces” option for the display mode Shaded:

You don’t, when Rhino joins the faces it will automatically align them. But this indicates that this process has probably not been done before, so I presume the surfaces has never been stiched together.

IGES HULL rebuilt to Solid.3dm (2.9 MB)

1 Like

Thanx for ‘ColorBackfaces’.
Found this.
Amazing visual!

Yes, I have Joined the faces at least a dozen different times (that is, a dozen long attempts at fixing this POS surface mess, which means I Joined and Exploded many times each try).

What I keep running into is the surfaces are mismatched. When I remake one from scratch using the perimeter edges of the surrounding surfaces and CurveNetwork, the result causes more problems. So I find myself chasing the surfaces around and around and getting nowhere. Good thing this is a learning experience and not work, b/c I have a full day and a 1/2 invested into learning how to do this on shyt IGES surfaces and getting nowhere!

Looks like you may have solved it, but I can’t read it into Inventor 2010 as 3dm. And I can’t read it into Rhino6 in order to SaveAs STEP. So I really can’t see if your model will work in Inventor. Is it possible for you to save it so I can read it into Rhino6 or maybe you can export it as STEP, so I can try it in Inventor?

I used the same tolerance and it failed to solidify in Inventor, even though the CompositeSurface came in OK. Also, I found a number of other errors in that surface. There were 2 overlapping surfaces at a tiny corner and the wedge surface near the back in the middle vertically didn’t meet up with the vertical seam on the adjoining surfaces. Lots of problems I kept trying to fix but without success.

V6 coming up!

IGES HULL rebuilt to Solid V6.3dm (2.9 MB)

Yeah, chaising surfaces… Been there done that :wink:
Test all kinds of tools for the job, networksrf is great for sketching, but can cause issues if your corners aren’t aligned well regarding curvature. And networksrf will give you seemingly good results even though there are gaps, without warning you, so you need to be careful.
Good luck on your journey! It’s 00:47 here so I’m logging off.

1 Like

This is the flip side of solidmodelers being so robust to produce watertight models:
They allow for tolerances on edges that may be in fact visible overlaps or holes.
As long as you stay in your MCAD modeller everything seems fine (as long as you don’t look to closely), when you export to programs that don’t follow this paradigm (e.g. surface modellers) sh*t hits the fan…

1 Like

Interesting, thanks for that info Norbert.

For clarification: by visible I mean visible if inspected very closely.

1 Like

Thanx for staying up to get this out to me.
I was brain dead by the time I got to it, so now I’m back at it today.
I exported your 3dm to STEP and brought it into Inventor, and it came in as a solid.
What do you know that I don’t?!
Any chance you can pass along what you did that made this work when hours upon hours of my attempts failed?
Is it that v7 has better Join and MatchSrf algorithms?
Maybe you can list your work-flow and what order you used the tools in and how?
Am I asking for too much?

That’s exactly what I kept seeing in my Inventor model with the original and with my re-worked mode…
But Holo’s closed model doesn’t show up any of that compared to the attempts I made to match the mismatched edges.

Mysteries abound!

Anyway, what can I read to understanding Tolerances in surface modeling for exporting to other apps?
That seems to be a big factor in this process.

You’re welcome.

I added those annotations to the file, even highlighted what surfaces was rebuilt and what was adjusted. From here on you have to try to fix those surfaces your self and just build experience.
Good luck!

OK. I guess it’ll take me weeks of trying all the combinations and permutations involved with using a dozen tools. I was just talking to my friend the other day about learning curves. I’ve done it before over a dozen times, let’s see if I can do it again with half a brain! Thanx for the clues!

Here’s a screen shot of all the NakedEdges in this model (Rhino6):

How in the world did you fix this model with only 4 edits?
Did you use another app or an add-on to Rhino for fixing imported surfaces?
Or do you have Macros you use?

1 Like

I just Joined all the surfaces of the ‘Original’ (post 23 above), then applied EdgeAnalysis>NakedEdges to it. The result was different from the surfaces I imported into my Rhino6 when doing the same thing.

I’d like to know why the results are different.

Is Rhino7 better at automatically fixing these IGES surfaces when opened in it?

Any one want to clue me in on this?

Then we need more info from you. What tolerance is your file in?

I finally figured out how to do it.
Had to do with finding and setting the tolerance right.
All the help in here got me moving in the right direction.
Check it out:
KCS_hull_SVA-0.3dm (2.4 MB)


Well done! Congratulations, hard work paying off is the best thing :wink:

1 Like

Thanks Holo And Cadman… Your discussion has solved my week long problem… I also downloaded the same model to do CFD analysis and was working on that and to my luck I have no experience of Rhino Software…
After that only one trick of tolerance i was also able to close the hull in seconds… So Week long hardwork has paid off… Really appreciated

1 Like

Here’s a related thread that was invaluable for figuring out how to fix this surface model.
It’s about tolerances.
Thanx Steve (spb)!

1 Like

Linked thread does not exist.