FitCrv Bug - Degree ignored


(David Cockey) #1

FitCrv ignores the Degree= option and always returns a Degree 1 polycurve if the input curve is a Degree 1 polycurve. If the input curve is Degree 2 or higher then the output is as specified in Degree=.


(Pascal Golay) #2

Hi David- that depends upon the angle tolerance used - at higher tolerance, kinks should be smoothed out with curves of the requested degree.It does look like higher degrees are not respected if any kinks remain in the curve (due to angle tolerance). So of the result is a polycurve, it stops at degree 3, if not, it will use the degree requested. Not sure what that is about… I’ll see what I can find out.

http://mcneel.myjetbrains.com/youtrack/issue/RH-28025

-Pascal


(David Cockey) #3

Thanks. Setting the angle tolerance to a very large amount such as 179 solves the problem.

AngleTolerance is currently not documented in the Help section on FitCrv.