First attempt at hops fails to create I/O

Hi Guys,

Just trying to get my first attempt at using HOPS working and I nothing appears on the HOPS component after setting the path to the attached GH file.

Is there something I’m missing?


Image 930
Image 929 (6.3 KB)

Found this random crash report after trying the above:

[ERROR] FATAL UNHANDLED EXCEPTION: System.ArgumentException: The path is not of a legal form.
at System.IO.Path.LegacyNormalizePath(String path, Boolean fullCheck, Int32 maxPathLength, Boolean expandShortPaths)
at System.IO.Path.InternalGetDirectoryName(String path)
at Hops.Servers.LaunchLocalRhinoCompute(Queue`1 serverQueue, Boolean waitUntilServing)
at Hops.Servers.GetComputeServerBaseUrl()
at Hops.RemoteDefinition.GetRemoteDescription()
at Hops.HopsComponent.DefineInputsAndOutputs()
at Hops.HopsComponent.set_RemoteDefinitionLocation(String value)
at Hops.HopsComponent.ShowSetDefinitionUi()
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Could this be related?

OK - if I recompute the GH Def the hops component pops up the error message:

In this case I’m using a URL to mwickerson’s github of hops enabled GH/C# scripts.

I also tried change to one version of HOPS back on Package Manger - still gives same error.



@stevebaer any suggestions on where I’m going wrong?

Hi -

That one runs correctly here.
Please run the Rhino SystemInfo command and copy-paste the result here.
Also, in the Grasshopper preferences, on the Solver page, change the settings so that the console window is shown and the server is launched at start:


Does that make the console appear after you have restarted Rhino and Grasshopper?

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Commercial, build 2022-03-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro M1000M (NVidia) Memory: 2GB, Driver date: 11-20-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.66
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-20-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\David Kay\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.16.22067.13001
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.16.22067.13001
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

Hi @wim

Thanks for your reply - SystemInfo details above.

Unchecking the Hide Rhino Compute Console Window and rebooting complete machine and Rhino/GH produces no Console.

It looks like Rhino Compute is not launching at all - is there a way for me to check and also someway for me to manually set it up?



I have a second (workshop/beater) machine here with R7 on it, tried this file and have exactly the same issue.



Just tried a full delete and reinstall of Rhino 7 too - no luck in getting Compute to start or HOPS to work.



Could there be a problem with one of my installed plugins that prevents Compute from starting?

How could I test for that?



Hi -

Thanks for checking that.
I’m in the same situation on my machine and it’s somewhat “good” to see that this is not an isolated case. I’ve put this on the list as COMPUTE-241.

I’m manually launching the compute server before starting Grasshopper on my PC.
In the Grasshopper preferences, on the Solver page, point the “Hops - Compute server” setting to the http://localhost:8081 URL and close Grasshopper and Rhino.


Then run the compute.geometry.exe file in

That should make Hops work on your machine.

To me, it’s unlikely that a plug-in would prevent the server from spinning up but something could get in the way of communicating with it… Could you list your plug-ins?
(I deleted a bunch of the plug-ins that I had installed and then started Grasshopper with loading-one-by-one without that making a difference on my machine…)

1 Like

Hi Win,


Manually starting Compute and pointing to the local host worked.

Now to see what I can do with this powerful new tool…



1 Like

@kiteboardshaper I was wondering if you could test something out for me. If you open the package manager and uninstall Hops 0.12.0 and reinstall 0.11.1… then restart Rhino and Grasshopper… does the rhino.compute console window then get launched? You’ll need to make sure the checkbox is unchecked to Hide Rhino.Compute Console Window in the Grasshopper settings. I’m just trying to see if there was some bug introduced in 0.12.0 which wasn’t there in 0.11.1. Thanks!

Hi Andy, I tried that yesterday and no luck - let me try it again now for you.



That’s ok. I think Wim’s computer also fails on 0.11.1 so something strange is going on… however, I can not replicate this issue on my machine. We’re digging into it.

Hi @AndyPayne, no luck with 0.11.1 today either.

Very strange that its on BOTH of my machines - tho I mirror all plugins etc on both.

The kicker is thanks to @wim suggestions on how to load Compute manually I have tested what I was trying to do -

Off load some looping work load from a compiled GH scripts using hops, hoping that they would run the same as on the native GH canvas.

Alas, I have the same problem with looping components in HOPS as Clusters/Grasshopper Player/Rhino Script Compiler compiled GH - these components will not run the same as on the canvas.

Any suggestions?

I’m leaning towards ‘node in code’ in some GH Python as my option of last resort.

Its a real shame as my stuff took a while to design/build, runs very well on the native canvas, but is completely useless for the final application.



Without seeing your definitions/code, it’s difficult to say why it would be failing. Are you able to provide a sample?

Hi @AndyPayne

Here is a simple example of a setup that works on the GH Canvas that will not work:

  • In a Cluster
  • In Grasshopper Player
  • In a compiled plug-in (using Rhino Script Complier)
  • On Compute/using HOPS

In my actual project I’ve used a combo of Octopus explicit components and Anemone Loops to create a genetic solver alternative to Galapagos.

In my complied to .RHP plugin I have a full user interface built using HumanUI and as such the user has no access to the GH canvas and therefore no access to the Galapagos UI to start/stop the solver.

My ‘roll your own’ has all the controls pulled out to the HumanUI interface and works PERFECTLY right up until I compiled to the .RHP and then the Octopus and Anemone components stop working.

Like I said - open to suggestions.



(PS - Yes I do believe I’m pushing the outside envelop with trying to do this in GH, but I’m so far down the rabbit hole now…)

220317_Loop example for (8.8 KB)

Thanks. So, there’s a lot going on here. I know at the moment that Galapagos does not work in Hops. I’ve only used Octopus a little bit, but I’m not convinced that it would work either. But, the simple Anemone script was helpful. Unfortunately, it does not look like looping of this sort is supported at this time via Hops. It’s definitely something we can to our todo list (I’m going to make a YouTrack issue for this shortly). But, I honestly don’t know what it would take to support this at the moment.