Filter window size


#1

This is a docked filter box.
It doesn’t know it’s size, and then shows a chevron for the not yet visible options.

The effect is seen right after starting Rhino.
On maximize window/normal state toggle this happens:

Also notice the appearance of the toolbar on normal state!


(Pascal Golay) #2

Hi Charles - thanks, I see this, at least partly…

when closing Rhino with a set-up like this:

here, it re-opens like this:

BTW, I’ve found that docking Filters to the left of the command line it pretty efficient in terms of screen real-estate, since the command area is generally wider than is really useful.

https://mcneel.myjetbrains.com/youtrack/issue/RH-39570

-Pascal


#3

Hello Pascal,

how do you do that?
In here, I can’t dock anything left to the command area.

Regarding the initially described error: Still the same in WIP (6.0.17172.1151, 21.06.2017).

I may not access this:
https://mcneel.myjetbrains.com/youtrack/issue/RH-39570
Any special reason?

Charles


(Pascal Golay) #4

HI Charles - I changed the bug item so that you can see it now, I hope. As for docking… if toolbar locking is not on, it should just work - float Filters and OSnaps, and then drag them up against the left or right edges of the Rhino window at one end or the other of the command area - drop when you see the blue preview rectangle show up in the right place.

Any luck?

-Pascal


#5

Hello Pascal,

yes, I have it docked.
I had to undock it first, then redock.
I tried to move it from docked state to docked state, which is expected to work, but doesn’t.
Ok, not a big deal.

The docked filters are pretty useless this way.
An idea is to have the filters as a menu in the Osnap box.
Then they are where they belong to, and they are always visible and accessible.

And look what happens on maximize/normal state:

Charles


(Pascal Golay) #6

Hi Charles - I have a request in to fix this problem, which bugs me as well - I think this is what you mean, right?
https://mcneel.myjetbrains.com/youtrack/issue/RH-37209

-Pascal