Filter mask exception

Hi all,
I just got a new computer and freshly installed revit 2019 and the newest WIP from October 22.

There’s a bug when you copy “Filter Mask…” component in grasshopper. Apparently i cant copy one and use another place, but i have to create a new one. There is something fishy going on in the background.

This means if i have a larger workflow that I want to duplicate then I have to recreate the Filter Mask components.


What kind of data are you connecting to the 'Value Set Picker" component?
Are Revit elements? Why is it empty if it has a list as input. Are all nulls?
I see in the screenshot that the component has a balloon. What does this ballon says?


Hi Kike,

It basically fails on a lot of inputs, and creates an exception error popup for each following component after it. (unique ones, so cant say skip all these errors).

The popup says that object reference is not set to an instance of an object.

It fails in this simple (6.5 KB)

I even tried to convert the elements output to text before inputting it to filter mask, still not working.

See attached. Thank you.

I made a change right now, could you please update and see.
You can update it from here.

hello @kike , just to add to the discussion, I am having issues with filter mask (Value Set Picker) when reopening the files… Replacing the filter mask component with a fresh one solves the problem, however, it reoccurs again when reopening the file.


Hey @danijelruso
The Filter Mask component is still being improved. Sorry for the inconveniences

Hi @danijelruso,

I’m testing it here and I’m unable to reproduce it.
Would you mind send us a .rvt file that contains some levels and the simplest .gh file that is failing on your case.