Filling "punctual holes"

Hello everybody,
Does anyone know how to fill or fix those punctual holes we sometime have in surface junction like on the picture below?
(without remodelling everything obviously :wink:

Thank you very much.

Good question.
I’d like to know too.
Those “punctual holes” often remain after fixing several complex open edges with the command.


Romain, can you please post the object, or send it to me via



Hi Pascal,

Please find here model with this problem. punctual holes sample.3dm (338.9 KB)
In this particular case, the problem is quite easy to fix by remodelling the surfaces. The major problem is to find which one of the four adjacent surface need to be rebuilt. It’s often a lot of wasted time. This problem often occurs when using the _JoinEdge command. It join the edges and left to “punctual holes” at the extremities. it’s also sometime appears at the junction of several complex surfaces even if all building curves are properly joined.

Thank you for getting involved

Hi Romain- thanks- it is actually possible to fix this by untrimming and re-intersecting, re trimming and then joinnig in just the right order if the moon is in the right part of the sky but it seems unnecessarily tricky to me- I’ll ask a developer to take a look.


I probably shouldn’t admit to this, but when I just need a watertight polysurface to send to the 3D printer, I make a tiny little sphere centered on the hole and boolean union it in. It can be so small it will be under the resolution of the printer, but it is quick and easy, and then you can move on to more productive work. I would stay away from Join Naked Edges, I think it is even a worse kluge than the one I just recommended.

There was a Webinar yesterday how to fix stuff like this. Should come online today.
Website (at the bottom):

Kyle will show how to deal with stuff like this. If you got an hour you will exactly know how to deal with this :wink:

  • Jordy

Hello. Thank you everybody.
@Mark, I have been thinkink about this solution, it’s effectively ok for rapide prototyping, but I would not like to send a file with many little sphere to the engineering studio…

@jordy1989 : Thank you for the link, I’ll give it a look.


Yes that is exactly the problem. Rhino fails to identify the bad surfaces in your model.

The 2 big flat surfaces in your model are the problem. They have bad 2d parameter curves. Rhino should catch this and flag those surfaces as bad objects.If you export your model to Rhino2 it finds the error in your model. Good error checking is still weakness in Rhino.

The problem is easy to fix when you know which surfaces are bad. Just extract the two bad surfaces and delete them and then use cap command to make your model a closed polysurface.