Fillett issue


#1

G’day McNeel, @pascal,

There’s a problem with filleting the bottom corners of the interior curves. Radius 50mm.

Rhino 5 - fillet problem.3dm(32.2 KB)

Process was:

  1. dupborder the plane
  2. explode result
  3. offset each side
  4. fillet at each corner
  5. top corners work but bottom corners don’t

I have worked around it but something isn’t right. Things that I checked:

  1. the dupborder curves fillet fine
  2. the offset corners look to be well within tolerance, “what” indicates as such
  3. trimming the corners worked with apparentintersections turned off
  4. the dupborder curves create a planarsrf readily but the offset ones do not
  5. tolerance seems suitable
  6. not exceptionally far from origin

regards,
Nick.


#2

Your interior U curve is invalid - I don’t know how it got that way… If you explode and rejoin, it fixes it and fillets work.

In starting from scratch, your example file seems to work fine here (filleting from the Front view), all 4 interior offset curve corners fillet…

–Mitch


#3

Thanks Mitch, I don’t know how it went silly, just that it did.