FilletEdge on simple Sweep1 creates naked edges


#1


(Menno Deij - van Rijswijk) #2

If you create the shape by boolean union of two curve extrusions, the fillet is OK.CurveExtrusions.3dm (83.6 KB)


#3

There are often several ways to create the object you have in mind, experiment with different methods. You’ll quickly learn how to create clean geometry. Before you fillet it use the ‘merge all faces’ command and see what happens…






#4

Hi Menno and 2DCube,
I am aware that there are workarounds but in this case I need to apply surface map that follows Sweep1 surface. I think this simply should work without any workarounds. Also Sweep1 creates degree 3 edges curves with 4 points ( Nurbs sweep1 polysurface to a simple clean mesh? ) and seems impossible to obtain a clean mesh out of it.


(Pascal Golay) #5

Hi Violine - you are correct that this should work with no workarounds. The problem is in FilletEdge not correctly handling the edge between the two top faces where it meets the other three edges, not in the sweep. It is on the bug pile…

thanks,

-Pascal


#6

Thank you Pascal I keep my fingers crossed for (hopefully) an outstanding V6.


#7

Hi @violin,
If the problem is the mapping you can use the custom mapping option for the texture mapping and get a perfectly veneer around the shape.


#8

Hi Riccardo,
It’s one part of Rhino that I did not understand well, and I need to re-pass this Brian’s tutorial:


Thanks!


#9

if im correct if you allready apply the fillet on the curve, it should work without failing,…


#10

Hi Sabino, yes it works. The point is that you don’t always know in advance what is your desired shape and you must go back and lose time.