FilletEdge failure


#1

I’ve got an object here that for some reason fails to fillet (the smaller end) in the 06/21 WIP.filletedge wip fail.3dm (146.4 KB)


(Pascal Golay) #2

Hi Jim - the cone thing has a kink in it - DivideAlongCreases to sort it out but…how, why and why does it matter? I suppose offsetting is messed up by the crease, maybe? Still poking…

-Pascal


#3

Hi Pascal,

Yeah, it works in 5…


(Pascal Golay) #4

Yep, turns out this is fallout from making fillets editable - the filleting process splits at kinks and therefore has, potentially, a different edge tally at various points than the input object, which messes the ability to edit. I’m not sure what we can do here - Chuck said we might be able to split things as you select the first edge on a brep and show you the edges from that - this might be both laggy, depending, and somewhat disconcerting…

Meantime - how did you get the kinky object - was that by design or is Rhino doing it somehow?

thanks,

-Pascal


#5

Hmm, it was just revovled from a polyline made by inserting a knot into a Line.


(Pascal Golay) #6

Hi Jim - is CreaseSplitting enabled? If not, did you turn it off, or is Rhino free-lancing?

thanks,

-Pascal


#7

It is disabled. Not sure if I’ve deliberately set it one way or the other, don’t think I have.


#8

It seems like a setting that should be enabled by default, it’s rather troublesome having polylines extrude to single surfaces.


(Wim Dekeyser) #9

I’m not totally clear on what you are saying. That setting -is- enabled by default. There are many reported cases though, where it is disabled and nobody knows how it gets in that state. Are you saying that in the period between your two latest posts in this thread, this setting turned from enabled to disabled again without you having done so yourself?


(Pascal Golay) #10

Hi Jim - Yeah- as Wim says, splitting is supposed to be enabled. If this is being disabled behind your back, as seems to be the case, we need to fix that.

-Pascal