Fillet trouble

I am having trouble filleting this super easy and basic model. I really don´t understand why, I have done similar things a hundred times before and now it does not work. Can anyone tell me why?

This is the image… :slightly_smiling:

Have you double checked the top and bottom surfaces are part of the same polysurface that contains the edge you have filleted?

Any chance we can have a look at the original model if the problem persists?

Square box copy.3dm (131.0 KB)

It is so strange, today, making a new model, it worked and I dont´t see what I did different. I think the fillet function is very confusing. I send you the file “Square box copy”, the file from yesterday that did not work out, and the file from today that worked “Square box_1”.Square box_1.3dm (111.6 KB)

It looks to me like possibly you used FilletEdge in one case and FilletSrf in the other.


I think Pascal is on to it.
FilletSrf and FilletEdge are very different commands.
Here’s a link to a V4 White paper that will help you understand the differences so you aren’t confused:

Some of the techniques shown are no longer needed in V5, but the techniques shown for how to “manually” get the results you want are worth understanding.