Fillet surface problem


#1

Hi everyone,
Iam modelising a litle speaker for a personal project but whil I am trying to get a fillet surface of 0.01 on all these edge:


I encouter a problem as the surface delete itself.

this fillet is to get a nice shiny edge on the render and generally when it doesn’t want to make a fillet I add the effect on photoshop. But it happen so many times that I would like to understand how to solve this problem in general.

Thanks for your help

Paul


#2

Can you post a 3dm file?
Ciao Vittorio


#3

here is the file
Speakers - copie.3dm (127.3 KB)


(Pascal Golay) #4

Hi Paul- I’ll take a look at the file and the filleting, but for rendering you can save a lot of effort by using ApplyEdgeSoftening.

-Pascal


#5

Hi

I tried a few things like rebuilding the rim surface as a revolve and the self intersecting notch surface, the fillet still bombed. I got it to work with at .04mm. It looks to me like a geometric condition problem at the intersection of the fillets being too small (sliver like at .01).


(Pascal Golay) #6

The file tolerance is .01, which is the same as the fillet radius- that is unlikely to work- try to work at a tolerance that is at least 10x the size of the smallest feature. In this case changing tolerance to .001 helps.

Edit: sorry, and thanks David- I said the exact opposite of what I meant to- the tolerance should be 10x smaller than the smallest feature…

-Pascal


#7

Pascal --> I didn’t knew there was a specific tolerence for a file, how can i change that?
Also the option ApplyEdgeSoftening seems to be very interesting but I can’t find it.

Sratosfear --> So you think that the shape make it impossible to put fillet of 0.01? do you have an idea to do it in an other way?

Thanks


#8

Hi

Pascal was right the file tolerance is the issue. I should have checked that, I just assumed.


(David Cockey) #9

Pascal meant the the tolerance which is at least 1/10 of the size of the smallest feature, not 10X the size. For example if the smallest feature is 0.01 then the absolute tolerance should be 0.001 or smaller.


(David Cockey) #10

To change model tolerances:

File tab > Properties > Document Properties > Units > Model > Units and tolerances

Or

DocumentProperties command > Units > Model > Units and tolerances


#11

ok thanks now it works perfectly :slight_smile: but i’m curious about the “ApplyEdgeSoftening” what is it and how can i use it?


(Pascal Golay) #12

Hi Paul- you can always check Help. Type the command at the command line, or find the icon on the Rendering Tools tab (Cyan filleted corner looking thing, center-right, or Render menu > Effects, then hit F1 to get the Help topic.

-Pascal


#13

thanks