Fillet problems post boolean


#1

Hello.

I’m fairly new to Rhino, been sing it for a couple of weeks, it’s very easy to use and I’m enjoying it. However I’ve discovered that after some boolean operations I am unable to chamfer of fillet the edges. I’m not sure how to post images here to this is a link to the problem.

https://onedrive.live.com/redir?resid=D96EE0343F940893!12167&authkey=!ADicsmSQbgN6bjc&v=3&ithint=photo%2c.png

I’m assuming I need to clean the surface after the boolean? I’ve Googled but cannot find anything, I think I do not know the correct terminology.

And help would be great, thanks.


(John Brock) #2

Hi
There are a few things to know about filleting and chamfering in Rhino.

  • The fillet can’t be so big that it runs off the edge of the surfaces it is following. It uses the surfaces as rails. If I have a box that is 1" wide and want to fillet/chamfer the top and bottom edges, the radius has to be less than 1/2" or the fillets will completely consume the surface and will fail.
  • The radius needs to be smaller than the curve of the edge it is following. If not, the resulting surface will self-intersect. That’s fine as far as a NURBS surface is concerned but not useful when representing an objects to be manufactured.
  • When using multiple fillet radius values, start with the large fillets first and work progressively to the smaller ones.

Here’s a link to an older V4 support page that covers these issues, Some of these limitations on V5 have been figured out for V5:
http://wiki.mcneel.com/rhino/advancedfilleting

Good luck


#3

Hello.

Thanks for that. However I still get issues. If I have say 50mm of space to play wit and perform a 2mm fillet, it’ll still fail. I believe the surface needs to be rebuilt/cleaned? It’s like it’s holding onto construction history.


(John Brock) #4

There has to be something specific going on there.
A small example file would be necessary to determine the actual problem now.


#5

I’ll get one hosted ASAP.


#6

Here is a file that shows this behaviour:

https://onedrive.live.com/redir?resid=D96EE0343F940893!12168

One end has been filleted with odd results, the other I have left alone for experimentation.


(John Brock) #7

Please send your email address to tech@mcneel.com, Attn: JB.
I have a short video to send you that shows the confusion and what the easy fix is.


(John Brock) #8

I dug your email address out of the Discourse Admin tools and sent you a flash video showing how to do what I think you want.

Let me know if I guessed wrong.


#9

Hello. Apologies, I have been away. I didn’t se an e-mail, I’ll go hunt through my junk folder and see if it got trapped. Thanks though, very helpful :slight_smile: