Fillet on radial corners. Quality?


#1

Hello everyone,

New user to Rhino here and first time poster.

I am trying to model an iPhone in Rhino just as a good learning process for modeling and handling CAD measurements and tight tolerances etc. The iPhone has a lot of radius corners and radied (?) cut outs in the metal body. These are the details I am trying to re-create in my model with high fidelity. As we all know nothing really has 90 degree sharp corners, and as such I am adding small fillets to every edge of the model.

The problem is, that when I make a cut out into a solid flat surface, with a rounded edge line, or object, and then fillet the resulting top-edge line of this cut out, the fillet sort of reduces the overall quality of the model and is not meeting my expectations for what the result should look like.

Overview of final example model;

Below are two screenshots showing the “problem”;

Corresponding to the results of point 8 in steps below.

Corresponding to the results of point 11 in steps below.

Example from my test model of the iPhone;

My Rhino version is : (5.9.40617.14345, 2014-06-17)

Steps To Reproduce;

  1. Start Rhino

  2. Start a new project with template Small Objects - Millimeters

  3. Create a solid box from 0, with 15x15x15 dimensions

  4. Create a rounded rectangle from 0, with 8x3 dimensions and a corner arc of 5

  5. Position the rounded rectangle roughly in the center of the box and slightly above the top surface of the box

  6. Create a cut out in the solid box with the rounded rectangle shape. You can use either MakeHole, WireCut or Extrude and Cap the rounded rectangle and do a Boolean Differense in the box to create a cut out. The depth should be about 3mm down into the box.

  7. Fillet the top edge line of the rounded rectangle with a radius of 0.25mm using the FilletEdge command.

  8. Zoom in to the rounded rectangle cut-out fillet and Observe the corner smoothness of the fillet edge. The quality of the fillet resolution is sub-par. (Use Shaded view or Rendered view, Perspective). The isocurve outlines intersect with the shaded box model mesh, meaning that the fillet edge detail is lower than that of the rounded rectangle curvature.

  9. Re-create this experiment but alter the rounded rectangle with the Rebuild command and set the values to;

Point count: 256

Degree: 11 (not sure if this affects the outcome or not, but just because we can, lets max it out)

  1. Perform steps 6 -> 8 again.

  2. Note that the fillet edge does not have a 1:1 cross-section curvature to the rebuilt rounded rectangle. There are more lines but the visual appearance of the fillet radius quality remains the same.

I tried using various methods and points and degrees and it never really comes out looking like I would expect, i.e. a near perfect, high resolution filleted edge.

The quality does increase a bit with higher Rebuild values, but it’s not “perfect” and I can’t really find a good intermediate value where I get acceptable results vs. creating a too “dense” model.

I realize most people model quality after the intented purpose for the model, but I thought with a CAD program like Rhino you wouldn’t have to compromise…

I also had a file from a training video which has this exact type of modeling done to it, and in this excercise file model, the same imperfections can be observed.

Questions;

  1. Am I doing something obviously wrong here which is affecting my quality of the radious fillet edge? Can I create the fillet a different way (automatically), or is there a setting which can be used to increase the quality of the fillet edge?

or

  1. Is it expected and acceptable that the filleted radious curvature of this nature has these types of imperfections?

I would prefer not having to rebuild these fillet edges manually for all corners I am doing this for.

But if this is as good as it can get with automated fillet, I am truly suprised and the low-resolution of the resulting mesh.

Obviously it is only really visible if zoomed in to a certain extent, but even with the full object in view I can still see hints of this imperfection.

I have searched for information about this on Google and on this as well as the old Rhino forum and found nothing that relates to my questions above.

Thanks.


#2

Take a look here:

http://www.hydraulicdesign.net/meshes.htm

Jim explains it well.

Dan


#3

Wow.

Thanks Dan.

That was extemely helpful and informative. Such a long post for such an easy answer… I feel stupid :expressionless:

I have done 3D previously but never knew about this.

The Mesh display settings help a lot so I can feel happy with the results.

Stupid computers! :wink:

Case closed!

Thanks for a great first experience on this forum :slight_smile:


#4

No problem. You should take a look at the training material Jim offers on that site. It’s extremely informative, even for long time Rhino users.

Dan


#5

Will do!

I actually sent Jim a thank you e-mail and referensed him back to this thread and your post as it was such an “a-hah!” moment for me, I figured he deserved it :smiley:


#6

Alright so spent a few hours modeling now. I am new in Rhino so it takes some time. I am doing a test modeling right now to proof my splines outlines and make sure there are no stupid mistakes.

After adjusting the Mesh resolution rendering settings I absolutely love it! :smiley:

I figured the least I could do was post back some pics of my iPhone 4S work in progress model.

Referense image layout

Referense splines layout

Shaded model so far. Doing the outer metal rim first.

Close up of buttons. Look at those smooth edges! :smiley:

Close up of SIM tray. Pushing it for Mesh resolution on this close up. But I feel good knowing it’s a Mesh rendering “problem” and not a modeling issue with Rhino NURBS!

Thanks again!


(Pascal Golay) #7

Not sure what is going on there, actually- can you post an image of the meshing settings that you’re using? Or maybe even the object itself?

thanks,

-Pascal


#8

Actually that is just an illusion in the screenshot. There is a 0.0125mm fillet edge on both sides of the SIM tray and they look kinda strange in the PNG image. What I meant was, if I zoom in something like 50% more, then I see some of the edges comeup, that I was refering to in my original post.

I am running the Smooth but Slower setting.

I tried the custom ones but that is overkill for now.

Thanks for your offer for help though :wink: