Fillet Edge opens my closed self-intersecting polysurface!

bezkrai.3dm (412.0 KB)
I’m trying to fillet the edges of this solid, but when I do so, the object becomes an open polysurface. What am I doing wrong and how can I fix this?

This was tricky. Your curves weren’t nicely aligned and the figure 8 had kinks. Next problem is the self intersection which was already mentioned in another topic I think.

To resolve the self intersection you need to split the closed surface and boolean union bit by bit.

See the result. I copied your object twice so you see step by step what I did with the solid.

bezkrai.3dm (4.8 MB)

Right, @Helvetosaur seemed to have fixed your figure 8 already…

Boolean Difference keeps failing! - Rhino / Rhino for Windows - McNeel Forum


I trimed the unwanted surfaces and joined the others back together to create the closed polysurface.
And now without the intersection when I fillet the edges it still creates an open polysurface.
bezkrai.3dm (427.9 KB)

I see 0.3 is too big of a fillet.

0.2 works, see the file attached

bezkrai_fillet.3dm (3.5 MB)

For example I fillet the top edges and it results as open polysurfacebezkrai (2).3dm (917.6 KB)
I wanted to know why it opens the solid when I fillet its edges.

The problem you’re facing has to do with the cross sections of your sweep. Less cross sections is better and I would orient the sections perpendicular to the rail. Your base curve aslo still had a kink, which is also just going to cause trouble. I moved the point so you can see it’s a kink

Less sections, better isocurves. Compare the isocurves with your object.

bezkrai_fillet.3dm (2.9 MB)

oh i am late with my file / answer…
martinsiegrist already pointed out the most important aspects:

  • build proper curves (interal G1 oder G2 )
  • split surfaces to remove self-intersection

my approach is not to use Sweep:


Thanks for taking your time It is still quite hard for me to do this as the final shape you got doesn’t match my preferences and when I try doing it by the steps you show me the end result is still an open polysurface. I will try Tom’s approach and see if I can pull it off.

No problem. There are a lot of details which aren’t really obvious at first… I think Tom’s approach is less problematic and you might have more control over the outcome.

Hi Tom!
I created my curves as I like them, but now I can’t quite figure out how to make the thinner line lower than the thicker one? I’m not very familiar with the loft command.

turn on control points
or F10
move partial control Points with Gumball aligned to world in z-direction

I extruded the surface, but I can’t trim the intersection surfaces. I tried creating the solid by using Sweep 2 and got the same result.krai krai.3dm (1.2 MB)

_explode … the closed Polysrf.
_delete … the surface at the bottom.
_split all 3 surfaces at the same position by isocurve, shrink = yes. pointsnap Knot.
split close to the middle of the surfaces. as the closed surface has a seam, split each surface once will result in 2x3 = 6 surfaces.
(send me a private message if you need paid rhino-lessons, i am based in Zürich / Switzerland)